0 1 背包

Problem Q

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 16   Accepted Submission(s) : 6
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …<br>The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?<br><center><img src=../../../data/images/C154-1003-1.jpg> </center><br>
 

Input
The first line contain a integer T , the number of cases.<br>Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2<sup>31</sup>).
 



Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
0 1 背包问题
动态方程就相当于 第i个包加不加
加的话 就是 取出前面 总体积减去当前体积的最大值
意思就是
for(i=1;i<=n;i++)
{
for{j=b[i];j<=v;j++)
{ dp[i][j]=max[dp[i-1][j],dp[i-1][j-b[i]]+a[i]];
}
ac 代码
#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
 int a[1000];
    int b[1000];
    int pao[1000][1000];
int main()
{
    int t;
    cin>>t;

    while(t--)
    {   memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(pao,0,sizeof(pao));
        int n,m;
        cin>>n>>m;
        int i,j;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);           //价值
        }
        for(j=1;j<=n;j++)
        {
            scanf("%d",&b[j]);             //体积
        }
        for(i=1;i<=n;i++)
        {
            for(j=0;j<=m;j++)
            {
                if(j>=b[i])
                pao[i][j]=max(pao[i-1][j],pao[i-1][j-b[i]]+a[i]);
                else
                pao[i][j]=pao[i-1][j];

            }
        }
        cout<<pao[n][m]<<endl;
    }
    return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值