a+b problem 2

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory

Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3196 Accepted Submission(s): 1178
 
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output

            For each test case, you should output two lines. The first line is \\\\\\\"Case #:\\\\\\\", # means the number of the test case. The second line is the an equation \\\\\\\"A + B = Sum\\\\\\\", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
 ac 
this problem pe
i am very angry!!;
ac daima
#include<iostream>
#include<stack>
#include<string.h>
#include<string>
#include <algorithm>
using namespace std;
int paopao(char x)
{
    if(x=='0')
        return 0;
    if(x=='1')
        return 1;
    if(x=='2')
        return 2;
    if(x=='3')
        return 3;
    if(x=='4')
        return 4;
    if(x=='5')
        return 5;
    if(x=='6')
        return 6;
    if(x=='7')
        return 7;
    if(x=='8')
        return 8;
    if(x=='9')
        return 9;
}
char paopaopao(int x)
{
    if(x==0)
        return '0';
    if(x==1)
        return '1';
    if(x==2)
        return '2';
    if(x==3)
        return '3';
    if(x==4)
        return '4';
    if(x==5)
        return '5';
    if(x==6)
        return '6';
    if(x==7)
        return '7';
    if(x==8)
        return '8';
    if(x==9)
        return '9';

}
int main()
{
    int t;
    cin>>t;
    string a;
    string b;
    int a1,b1;
    int pao;
    int i,j;
    string x;
    int pao1;
    int pao2;
    int pao3;
    int k;
    k=1;
    int qq;
    string e1;
    string e2;
    while(t--)
    {
        cin>>a>>b;
        x="";
        string aa;
        a1=a.length();
        b1=b.length();
        e1=a;
        e2=b;
        reverse(a.begin(),a.end());
        reverse(b.begin(),b.end());
        if(a1>b1)
          {
              qq=a1;
              a1=b1;
              b1=qq;
              aa=a;
              a=b;
              b=aa;
          }
          pao=0;

        for(i=0;i<a1;i++)
        {
            pao1=paopao(a[i]);
            pao2=paopao(b[i]);
            pao3=pao1+pao2+pao;
            if(pao3>=10)
            {
                pao=pao3/10;
                pao3=pao3%10;

            }
            else
            {
                pao=0;
            }
            x=x+paopaopao(pao3);
        }
        for(i=a1;i<b1;i++)
        {
            pao1=paopao(b[i]);
            pao3=pao1+pao;
            if(pao3>=10)
            {
                pao=pao3/10;
                pao3=pao3%10;
            }
            else
                pao=0;
            x=x+paopaopao(pao3);
        }
        reverse(x.begin(),x.end());
        reverse(a.begin(),a.end());
        reverse(b.begin(),b.end());
        cout<<"Case "<<k++<<":"<<endl;
        cout<<e1<<" + "<<e2<<" = ";
        if(pao>0)
        cout<<paopaopao(pao);
        cout<<x;
        cout<<endl;
       if(t==0)
           break;
       else
            cout<<endl;

    }
    return 0;
}


Author
Ignatius.L
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值