A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 337902 Accepted Submission(s): 65560
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
由于超过整型能计算的范围,所以需要用字符串来特殊处理
AC代码
#include <stdio.h>
#include <string.h>
char s1[1000+10];
char s2[1000+10];
char s[1000+10];
int main()
{
int n;
scanf("%d",&n);
int k=0;//输出样例序号
int flag=0;//输出格式控制标记
while(n--)
{
memset(s2,0,sizeof s1);
memset(s2,0,sizeof s2);
memset(s,0,sizeof s);
scanf("%s",s1);
getchar();
scanf("%s",s2);
getchar();
int len1=strlen(s1);
int len2=strlen(s2);
int cnt=0;
int ok=0;//用来记录是否进位
if(len1>len2)
{
while(len1)
{
int cp;
if(len2!=0)
{
cp=ok+s1[--len1]+s2[--len2]-'0'-'0';
}
else
cp=ok+s1[--len1]-'0';
if(cp<10)
{s[cnt++]=cp+'0';ok=0;}
else
{s[cnt++]=cp%10+'0';ok=1;}
// printf("%c++len1=%d len2=%d++\n",s[cnt],len1,len2);
}
if(ok==1)
s[cnt++]='1';
s[cnt]='\0';
}
else if(len1<=len2)
{
while(len2)
{
int cp;
if(len1!=0)
{
cp=ok+s1[--len1]+s2[--len2]-'0'-'0';
}
else
cp=ok+s2[--len2]-'0';
if(cp<10)
{s[cnt++]=cp+'0';ok=0;}
else
{s[cnt++]=cp%10+'0';ok=1;}
//printf("%c++len1=%d len2=%d++\n",s[cnt],len1,len2);
}
if(ok==1)
s[cnt++]='1';
s[cnt]='\0';
}
if(flag++!=0)
printf("\n");//输出格式控制
printf("Case %d:\n",++k);
printf("%s + %s = ",s1,s2);
int i;
for(i=cnt-1; i>=0; i--)//正向储存,反向输出
printf("%c",s[i]);
printf("\n");
}
return 0;
}
我基本是按思路来写,看了一下别人的代码,简洁不少,算法一样
#include<stdio.h>
#include<string.h>
int main()
{
char a[1000],b[1000],c[1001];
int i,j=1,p=0,n,n1,n2;
scanf("%d",&n);
while(n)
{
scanf("%s %s",a,b);
printf("Case %d:\n",j);
printf("%s + %s = ",a,b);
n1=strlen(a)-1;
n2=strlen(b)-1;
for(i=0;n1>=0||n2>=0;i++,n1--,n2--)//把我的二合一了,很厉害
{
if(n1>=0&&n2>=0){c[i]=a[n1]+b[n2]-'0'+p;}
if(n1>=0&&n2<0){c[i]=a[n1]+p;}
if(n1<0&&n2>=0){c[i]=b[n2]+p;}
p=0;
if(c[i]>'9'){c[i]=c[i]-10;p=1;}
}
if(p==1){printf("%d",p);}
while(i--)
{printf("%c",c[i]);}
j++;
if(n!=1){printf("\n\n");}
else {printf("\n");}
n--;
}
}
这题还有个思路,就是把两个串变成等长,短串前面补0,最后直接加
例如123456 + 546 ,可以变成123456 + 000456 ,这样直接加起来,不用考虑长度问题
但是呢又要多一步把短串补0,也挺麻烦
目前还米有更好的思路。。。