Time limit 1000 ms
Memory limit 65536 kB
OS Linux
Source East Central North America 1998
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT
Sample Output
CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA
水一波。
给出DNA序列,求解每条序列的逆序对数,并按逆序对数从小到大排列。关键是如何求解逆序对数。
#include <iostream>
#include <ios>
#include <cstring>
#include <algorithm>
using namespace std;
struct node{
char s[60];
int n;
}a[110];
int f(char s[]){
int t = 0;
for(int i = 0; i < strlen(s); i++){
for(int j = i + 1; j < strlen(s); j++){
if(s[i] > s[j]) t++;
}
}
return t;
}
int cmp(node a, node b){
return a.n < b.n;
}
int main(){
ios::sync_with_stdio(0);
int n, m;
cin >> n >> m;
for(int i = 0; i < m; i++){
cin >> a[i].s;
a[i].n = f(a[i].s);
}
sort(a, a + m, cmp);
for(int i = 0; i < m; i++) cout << a[i].s <<endl;
return 0;
}