Brackets(poj-2955)(区间dp)

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8762 Accepted: 4690

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source


#include<algorithm>
#include<string.h>
#include<stdio.h>
#include<map>
using namespace std;
int dp[500][500];
int cmp(char a,char b)
{
    if(a=='['&&b==']')
        return 1;
    else if(a=='('&&b==')')
        return 1;
    else
        return 0;
}
int main()
{
    char s[2000];
    while(scanf("%s",s)!=EOF)
    {
        if(strcmp(s,"end")==0)
            return 0;
        memset(dp,0,sizeof(dp));
        int n=strlen(s);
        for(int i=0;i<n-1;i++)
        {
            if(cmp(s[i],s[i+1]))
            {
                dp[i][i+1]=2;
            }
        }
        for(int i=2;i<n;i++)
        {
            for(int j=0;j<n-i;j++)
            {
                int k=j+i;
                dp[j][k]=0;
                if(cmp(s[j],s[k]))
                {
                    dp[j][k]=dp[j+1][k-1]+2;
                }
                 for(int v=j;v<k;v++)
                 {
                     dp[j][k]=max(dp[j][v]+dp[v+1][k],dp[j][k]);
                 }
            }
        }
        printf("%d\n",dp[0][n-1]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值