POJ_2253(最短路问题变形)

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19919 Accepted: 6460

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
 
题目意思大体就是找一条路,这条路中每一跳都尽量的小。找到这条路中最大的边。。开始没看懂意思。。得加强看英语题目的能力!!!!
 
#include "stdio.h"
#include<algorithm>
#include<cmath>
using namespace std;

const int maxV = 1001;
const int maxE = 2001;
const int maxLen = 999999;
int n;
double dist[maxV];
double length[maxV][maxV];
int i,j;
struct node
{
	int x;
	int y;
};
node dot[1000];

double Dijkstra()
{
	bool s[maxV];
	for(i=1;i<=n;++i)
	{
		s[i]=0;
		dist[i]=length[1][i];
	}
	s[1]=1;
	dist[1]=0;
	double max = 0;
	for(i=2;i<=n;++i)
	{
		
		double temp = maxLen;
		int u = 1;
		for(j=1;j<=n;++j)
		{
			if(!s[j]&&dist[j]<temp)
			{
				u = j ;
				temp = dist[j];
			}
		}

		if(temp>max)
			max = temp;
		if(u==2)
			return max;
		s[u]=1;
		for(j=1;j<=n;j++)
		{
			if(!s[j]&&dist[j]>length[u][j])
				dist[j]=length[u][j];
		}
	}

}
int main(int argc, char* argv[])
{

	
	int a,b;
	int count=1;
//FILE *fp = freopen("data.txt","r",stdin);
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0) break;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				length[i][j]=maxLen;
		for(i=1 ; i<=n;i++)
		{
			scanf("%d%d",&a,&b);
			dot[i].x=a;
			dot[i].y=b;
		}
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				length[i][j]=sqrt((dot[i].x-dot[j].x)*(dot[i].x-dot[j].x)+(dot[i].y-dot[j].y)*(dot[i].y-dot[j].y));
		printf("Scenario #%d\nFrog Distance = %.3f\n\n",count++,Dijkstra());

	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值