poj 2253 Frogger

Frogger

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
 

最短路问题:

找从一点到某一点的连通路中最大的一条边长;

dijkstra算法,有点变形,不用构建一个完整的通路,到达一个特定点就行了。

很简单的一道题目,但是因为以前做过,结果在没完全理解题意的清苦下一直wrong!!再次提醒一定要仔细读题。。

 

<pre code_snippet_id="199875" snippet_file_name="blog_20140222_1_7630877" class="cpp" name="code">#include"stdio.h"
#include"string.h"
#include"math.h"
#define N 205
int map[N][N],dis[N],ans;
int mark[N],n;
struct node
{
	int x,y;
}f[N];
int Dis(int x1,int y1,int x2,int y2) //求两点间平方和,最后得到答案后再取平方根
{
	int x=x1-x2,y=y1-y2;
	return x*x+y*y;
}
void dijkstra()
{
	int i,index,min;
	memset(mark,0,sizeof(mark));
	mark[0]=1;
	for(i=0;i<n;i++)
		dis[i]=map[0][i];
	ans=0;
	while(1)
	{
		index=0;
		min=1e8;
		for(i=0;i<n;i++)
			if(!mark[i]&&dis[i]<min)
			{
				index=i;
				min=dis[i];
			}
		if(ans<min)  //注意顺序
			ans=min;
		if(index==1)
			break ;
		mark[index]=1;
		for(i=0;i<n;i++)
			if(!mark[i]&&dis[i]>map[index][i])
				dis[i]=map[index][i];
	}
}
int main()
{
	int i,j,cnt=1;
	while(scanf("%d",&n)&&n)
	{
		for(i=0;i<n;i++)
			scanf("%d%d",&f[i].x,&f[i].y);
		for(i=0;i<n;i++)
		{
			map[i][i]=0;
			for(j=i+1;j<n;j++)
				map[i][j]=map[j][i]=Dis(f[i].x,f[i].y,f[j].x,f[j].y);
		}
		dijkstra();      
		printf("Scenario #%d\n",cnt++);
		printf("Frog Distance = %.3f\n\n",sqrt(1.0*ans));
	}
	return 0;
}

 
 

                
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值