POJ_2349(kruskal)

Arctic Network
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7187 Accepted: 2426

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13
 
完全可以作为阅读理解做!!开始纠结为什么案例结果不是200.00,后来多读几遍题后发现 卫星是在每个点上,两个有卫星的点之间可以通信。所以2个卫星其实只有一条路径。其实就是求MST过程中的第p-s条边。
代码如下:
 
#include "stdio.h"
#include<math.h>
#include<algorithm>
using namespace std;

const int MaxV = 1000;
const int MaxE = 150000;
int father[MaxV];
int heavy[MaxV];

struct Point
{
	int x;
	int y;
}point[MaxV];

struct Edge
{
	int p1;
	int p2;
	double length;
}e[MaxE];

int findRoot(int i)
{
	return i==father[i]?i:findRoot(father[i]);
}

bool join(int x,int y)
{
	int root1 = findRoot(x);
	int root2 = findRoot(y);
	if(root1==root2)
		return false;
	if(heavy[root1]>=heavy[root2])
	{
		father[root2]=root1;
		heavy[root1]+=heavy[root2];
	}
	else
	{
		father[root1]=root2;
		heavy[root2]+=heavy[root1];
	}
	return true;
}
bool cmp(const Edge  a,const Edge  b)
{
	return a.length<b.length;
}

int main()
{
	int n,s,p,i,j,temp,count;
	//FILE *fp = freopen("data.txt","r",stdin);
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&s,&p);
		for(i=1;i<=p;i++)
		{
			scanf("%d%d",&point[i].x,&point[i].y);
			father[i]=i;
			heavy[i]=i;
		}
		temp=0;
		for(i=1;i<=p;i++)
			for(j=1;j<=i;j++)
			{
				if(i==j)continue;
				temp++;
				e[temp].p1=i;
				e[temp].p2=j;
				e[temp].length=sqrt((double)(point[i].x-point[j].x)*(point[i].x-point[j].x)+(point[i].y-point[j].y)*(point[i].y-point[j].y));
			}
			sort(e+1,e+1+temp,cmp);
			count=0;	
		for(i=1;i<=temp;i++)
		{
			if(join(e[i].p1,e[i].p2))
			{
				count++;
				if(count==p-s)
				{
					printf("%.2f\n",e[i].length);
					break;
				}
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值