poj 2349

Arctic Network
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24412 Accepted: 7523

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

题目大意:我这个水货题意理解了半天才搞明白啥意思。题目大意是说,现在有n个点之间建立信息通讯的通道,有两种不同的连接方式,一种是卫星进行信息来往,另一种是直接无线电进行信息来往。不过对于卫星往来的线路,只有m个设施能使用,用拥有卫星设施的点之间可以互相连接,对于没有卫星设施的点只能依靠无线电进行通讯,为使费用最低,无线电的通讯设施所覆盖的范围应该最小,并且所有的无线电设施都是一样的,现在问题是让求出这种无线电的最小覆盖的范围,使得这些点之间直接或者间接的联通。

解题思路:首先这些点之间应该是直接或者间接的连接的,因此需要用到最小生成树。之后对于该最小生成树的每一条边进行选择,将卫星设施使用上,之后剩下的就是需要用到无线设施的点。当然了,如果需要范围最小,不就是所剩的边最小,因此,对于n个点的图,有n-1条边,对于m个设施,可以去掉m-1个边,对边按从小到大进行排序,之后去掉前m-1条大边,剩下的第m个边就是所求

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int cmp(double a,double b)
{
	return a>b;
}
#include<math.h>
double fun(int x,int y,int x2,int y2)
{
	return  sqrt((x-x2)*(x-x2)+(y-y2)*(y-y2));
}	
double a[510][510];
int b[510];
double dis[510];
int main()
{
	int i,j,k,m,n,t,c;
	double min,z;
	scanf("%d",&t);
	int x[510],y[510];
	while(t--)
	{
		scanf("%d%d",&m,&n);
		for(i=1;i<=n;i++)
			scanf("%d%d",&x[i],&y[i]);
		for(i=1;i<=n;i++)
		{
			for(j=i+1;j<=n;j++)
			 a[i][j]=a[j][i]=fun(x[i],y[i],x[j],y[j]);
		}
		for(i=1;i<=n;i++)
		  dis[i]=a[1][i],b[i]=0;
		c=1;
		b[1]=1;
		while(c<n)
		{
			min=99999999;
			for(i=1;i<=n;i++)
			{
				if(!b[i]&&min>dis[i])
				  min=dis[i],j=i;
			}
			b[j]=1;c++;
			for(k=1;k<=n;k++)
			{
				if(!b[k]&&a[j][k]<dis[k])
				  dis[k]=a[j][k];
			}
		}
		sort(dis+1,dis+n+1,cmp); 
	   printf("%.2f\n",dis[m]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值