【PAT B1040/A1093】 Count PAT’s

26 篇文章 1 订阅
16 篇文章 0 订阅

The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10
​5
​​ characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

思路一:参考《算法笔记》。对于一个确定位置的A来说,由它构成的PAT个数=A之前P的个数乘A之后T的个数。用p[i]记录第i个位置前P的个数,再从尾到头遍历,用sumT记录当前T的个数,如果遇到T则sumT++,如果遇到A则ans更新。

#include <cstdio>
#include <cstring>

const int MOD = 1000000007;
const int maxn = 100010;
char str[maxn];
int p[maxn];

int main() {
    scanf("%s", str);
    int i,sumT = 0, ans = 0;
    int len = strlen(str);
    for (i = 0; i < len; i++) {
        if (i) {//如果i不是首位
            p[i] = p[i - 1];//继承上一位的结果
        }
        if (str[i] == 'P') {//如果当前位置字符是P
            p[i] = p[i - 1] + 1;
        }
    }
    for (i = len - 1; i >= 0; i--) {//一边遍历一边计算结果
        if (str[i] == 'T') {
            sumT++;
        } else if (str[i] == 'A') {//更新结果
            ans = (ans + p[i] * sumT) % MOD;
        }
    }
    printf("%d", ans);
}

思路二:并不用每次都记录。先遍历一遍得到T的总个数,然后再遍历一遍并同时计算即可。

#include <iostream>
#include <string>

using namespace std;

const int MOD = 1000000007;

int main() {
    string s;
    cin >> s;
    int len = s.length(), result = 0, countp = 0, countt = 0;
    for (int i = 0; i < len; i++) {//得到T总个数
        if (s[i] == 'T')
            countt++;
    }
    for (int i = 0; i < len; i++) {
        if (s[i] == 'P') countp++;
        if (s[i] == 'T') countt--;
        if (s[i] == 'A') result = (result + (countp * countt)) % MOD;
    }
    cout << result;
    return 0;
}

参考链接:link

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值