问题 A: 二叉排序树

题目描述
输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。

输入
输入第一行包括一个整数n(1<=n<=100)。接下来的一行包括n个整数。

输出
可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。每种遍历结果输出一行。每行最后一个数据之后有一个空格。

样例输入

1
2 
2
8 15 
4
21 10 5 39 

样例输出

2 
2 
2 
8 15 
8 15 
15 8 
21 10 5 39 
5 10 21 39 
5 10 39 21 

思路:常规思路,注意如果输入数字和前一个数字相等时直接返回。

#include <cstdio>

typedef struct BiNode {
    int data;
    struct BiNode *lchild, *rchild;
} BiNode, *BiTree;

void insert(BiTree &root, int data) {
    if (root == nullptr) { //到达空结点时,即为需要插入的位置
        root = new BiNode;
        root->data = data;
        root->lchild = root->rchild = nullptr;
        return;
    }
    if (data == root->data) {
        return;
    } else if (data < root->data) {
        insert(root->lchild, data);
    } else {
        insert(root->rchild, data);
    }
}

void preOrder(BiTree root) { //先序遍历
    if (root == nullptr) return;
    printf("%d ", root->data);
    preOrder(root->lchild);
    preOrder(root->rchild);
}

void inOrder(BiTree root) { //中序遍历
    if (root == nullptr) return;
    inOrder(root->lchild);
    printf("%d ", root->data);
    inOrder(root->rchild);
}

void postOrder(BiTree root) { //后序遍历
    if (root == nullptr) return;
    postOrder(root->lchild);
    postOrder(root->rchild);
    printf("%d ", root->data);
}

int main() {
    int n, data;
    while (scanf("%d", &n) != EOF) {
        BiNode *root = nullptr;
        for (int i = 0; i < n; i++) {
            scanf("%d", &data);
            insert(root, data);
        }
        preOrder(root);
        printf("\n");
        inOrder(root);
        printf("\n");
        postOrder(root);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值