题目描述
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
输入
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。
当N为0时输入结束。
输出
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
样例输入
4
1 2 1 1
1 3 6 0
1 4 2 1
2 3 3 0
2 4 5 0
3 4 4 0
3
1 2 1 1
2 3 2 1
1 3 1 0
0
样例输出
3
0
思路:Kruskal算法。修建状态为1相当于两条边对应边权为0。
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXV = 110;
const int MAXE = 10010;
//边集定义部分
struct edge {
int u, v;
int cost;
} E[MAXE];
bool cmp(edge a, edge b) {
return a.cost < b.cost;
}
//并查集部分
int father[MAXV];
int findFather(int x) {
int a = x;
while (x != father[x]) {
x = father[x];
}
//路径压缩(可不写)
while (a != father[a]) {
int z = a;
a = father[a];
father[z] = x;
}
return x;
}
int kruskal(int n, int m) { // n个顶点,m条边
int ans = 0, Num_Edge = 0;
for (int i = 1; i <= n; i++) { //编号为[1,n]
father[i] = i;
}
sort(E, E + m, cmp);
for (int i = 0; i < m; i++) {
int fU = findFather(E[i].u);
int fV = findFather(E[i].v);
if (fU != fV) {
father[fU] = fV;
ans += E[i].cost;
Num_Edge++;
if (Num_Edge == n - 1) break;
}
}
if (Num_Edge != n - 1) {
return -1;
} else {
return ans;
}
}
int main() {
int N, len, key;
while (scanf("%d", &N), N != 0) {
for (int i = 0; i < N * (N - 1) / 2; i++) {
scanf("%d%d%d%d", &E[i].u, &E[i].v, &E[i].cost, &key);
if (key == 1) E[i].cost = 0;
}
len = kruskal(N, N * (N - 1) / 2);
printf("%d\n", len);
}
return 0;
}