PATB1044 火星数字 (20 分)

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

题解:

模拟题,解题思路还是比较清晰明了的,代码中我用了substr()与stoi()函数,好用到爆,强烈建议花3分钟学一下

代码注释里,博主写了string转int的两种方法,这里不再赘述。

#include <iostream>
#include <string>
using namespace std;
void func1(string s);
void func2(string s);
string a[13] = {"tret","jan","feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string b[13] = {"###","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
int main(){
	int n;
	cin >> n;
	getchar();
	string s;
	for(int i = 0; i < n; ++i){
		getline(cin, s);
		if(s[0] >= '0' && s[0] <= '9') 
			func1(s);
		else func2(s);
	}
	return 0;
}
void func1(string s){
	/*string转int方法不止一种,除了下面之外还有: 
	int len = s.size();
	int num = 0;
	for(int i = 0; i < len; ++i)
		num = num * 10 + (s[i] - '0');*/
	string t = s.substr(0);//substr()和stoi()函数真的好用,建议百度用法并记下来 
	int num = stoi(s);
	if(num <= 12){
		cout << a[num] << endl;
	}
	else if(num % 13 == 0){
		cout << b[num / 13] << endl;
	}
	else cout<< b[num / 13] << " " << a[num % 13] << endl;
}
void func2(string s){
	int len = s.length();
	if(len == 3){
		for(int i = 1; i <= 12; ++i){
			if(s == a[i])
				cout << i << endl;
			else if(s == b[i])
				cout << i * 13 << endl;
		}
	}
	else{
		int t1 = 0;
		int t2 = 0;
		string t, p;
		t = s.substr(0, 3);
		p = s.substr(4, 3);
		for(int i =1; i <= 12; i++){
			if(t == b[i]) t1 = i;
			if(p == a[i]) t2 = i;
		}
		cout << t1 * 13 + t2 << endl;
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值