01-复杂度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices iand j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

 

=======================================================================

找最大子列和很简单。(如果你觉得不简单请点这里,这是最大子列和的基础版本,学完再回来)

题目还要求输出 最大子列和的 起始元素,和结束元素

 

寻找起始下标:不难看出,当thisSum = 0时,新子串开始。因为新子串 有可能 是最大子串,所以我们用临时变量把这个新子串的起始下标保存下来。随着遍历的进行,如果这个新子串 确实是 最大子串,那么,就找到了起始下标。

寻找结束下标:这个很简单,每一次更新maxSum时,顺带更新 结束下标。

因为所有的输入都保存在数组 v[n] 里,所以我们输出 v[起始下标] , v[结束下标]。

 

坑1:把 起始下标,和结束下标输出了...the first and the last numbers 而不是 index...

出题人故意挖的坑,把样例的数字设置的和下标一致,都是1和4...(读题不谨慎,亲人两行泪啊)

其他还有几个坑是自己的原因,我把它们写在代码注释里了。

======================================================================

#include <iostream>
#include <vector>
using namespace std;
int main(){
	int n, maxSum = -1, thisSum = 0; 
	cin >> n;
	int left = 0, right = n-1, temp_index = 0;    //坑2:我曾这一行与上一行位置互换,我是ZZ
	vector<int> v(n);    //坑3:我把这个v后面的(n)漏了,cin>>v[i]出不来结果。
	for(int i = 0; i < n; ++i){
		cin >> v[i];
		thisSum += v[i];
		if (thisSum < 0) {
			thisSum = 0;
			temp_index = i + 1;
		} else if (thisSum > maxSum) {
			maxSum = thisSum;
			left = temp_index;
			right = i;
		}
	}
	if(maxSum < 0) maxSum = 0;
	printf("%d %d %d", maxSum, v[left], v[right]);	
	return 0;
} 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值