1154 Vertex Coloring (25 分)
A proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.
Now you are supposed to tell if a given coloring is a proper k-coloring.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains Ncolors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.
Output Specification:
For each coloring, print in a line
k-coloring
if it is a properk
-coloring for some positivek
, orNo
if not.Sample Input:
10 11 8 7 6 8 4 5 8 4 8 1 1 2 1 4 9 8 9 1 1 0 2 4 4 0 1 0 1 4 1 0 1 3 0 0 1 0 1 4 1 0 1 0 0 8 1 0 1 4 1 0 5 3 0 1 2 3 4 5 6 7 8 8 9
Sample Output:
4-coloring No 6-coloring No
========================================================
题意:
给定 顶点个数 n 和 m 个顶点对(代表这俩顶点有边。
接着给了 K 组值,每组有 n 个值,是 0 至 n-1 号顶点的value值。
如果任一连通(有边)的顶点间,value值都不同,则输出不重复的value的个数。只要有一组相同,输出No。
解题:
其实没必要建图,题目给了 m 个顶点对。遍历这 m 个顶点对,判断俩顶点的value值是否相同。
另外,用set去重可统计不重复的value个数。
========================================================
#include <iostream>
#include <vector>
#include <set>
using namespace std;
struct node{
int t1, t2;
};
int main(){
int n, m, k;
cin >> n >> m;
vector<node> v(m);
for(int i = 0; i < m; i++)
scanf("%d %d", &v[i].t1, &v[i].t2);
cin >> k;
while(k--){
int a[10005] = { 0 };
bool flag = true;
set<int> se;
for(int i = 0; i < n; i++){
scanf("%d", &a[i]);
se.insert(a[i]);
}
for(int i = 0; i < m; i++){
if(a[v[i].t1] == a[v[i].t2]){
flag = false;
break;
}
}
if(flag)
printf("%d-coloring\n", se.size());
else
printf("No\n");
}
return 0;
}