POJ 2242|ZOJ 1090 The Circumference of the Circle

The Circumference of the Circle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7915 Accepted: 4808

Description

To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't? 

You are given the cartesian coordinates of three non-collinear points in the plane. 
Your job is to calculate the circumference of the unique circle that intersects all three points. 

Input

The input will contain one or more test cases. Each test case consists of one line containing six real numbers x1,y1, x2,y2,x3,y3, representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.

Output

For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately 3.141592653589793.

Sample Input

0.0 -0.5 0.5 0.0 0.0 0.5
0.0 0.0 0.0 1.0 1.0 1.0
5.0 5.0 5.0 7.0 4.0 6.0
0.0 0.0 -1.0 7.0 7.0 7.0
50.0 50.0 50.0 70.0 40.0 60.0
0.0 0.0 10.0 0.0 20.0 1.0
0.0 -500000.0 500000.0 0.0 0.0 500000.0

Sample Output

3.14
4.44
6.28
31.42
62.83
632.24

3141592.65

题解:题意为,已知圆上的三点坐标,求圆的周长。

可以想到公式: C = 2*PI*R,主要是把R求出来。

列出一些R相关的公式: s = PI*R*R; s = r*C/2 (s,为面积,C为周长)

把面积求出,就可以得出R的值。可以通过海伦公式和三角形正弦定理得出。

根据3点可以求出三条边的长度,例如 a = sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2))两点之间的距离。同理可以得出b,c使用海伦公式求出面积

p = (a+b+c)/2, s = sqrt(p*(p-a)*(p-b)*(p-c))

使用三角形的正弦定理 a/sinA = b/sinB = c/sinC = 2R, R为外接圆的半径。

圆的面积公式为: S = bcsinA/2 = acsinB/2 = absinC/2;

sinA = a/2R -> S = bca/4R -> R = abc/4R

周长为:2*PI*R。

ACCode:

#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
using namespace std;
const double pi=3.141592653589793;
int main()
{
    double x1,y1,x2,y2,x3,y3,a,b,c,p,s,r,cir;
    while(cin>>x1>>y1>>x2>>y2>>x3>>y3)
    {
        a = sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
        b = sqrt((x1-x3)*(x1-x3)+(y1-y3)*(y1-y3));
        c = sqrt((x3-x2)*(x3-x2)+(y3-y2)*(y3-y2));

        p = (a+b+c)/2;
        s = sqrt(p*(p-a)*(p-b)*(p-c));
        r = (a*b*c)/(4*s);
        cir = 2*pi*r;
        printf("%.2lf\n",cir);

    }
    return 0;
}

参考:

http://ziyuan.wmw.cn/BD/beida/FileLibrary/directions/g1k3sxb443aa01/g1k3sxb443aa01.htm

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值