大数相加(hdu1002)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 348933    Accepted Submission(s): 67756


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include<stdio.h>
#include<string.h>
int main()
{
    int t,j=1,flag2=0;
    scanf("%d",&t);
    int a[10010],b[10010],c[10010];
    char str1[10010],str2[10010];
    while(t--)
    {
        if(flag2==1)
            printf("\n");
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        scanf("%s%s",str1,str2);
        int k,i;
        int len1,len2,len_max;
        len1=strlen(str1);
        len2=strlen(str2);
        for(i=0; i<len1; i++)
            a[i]=str1[len1-1-i]-'0';
        for(i=0; i<len2; i++)
            b[i]=str2[len2-1-i]-'0';
        if(len1>len2)
            len_max=len1;
        else
            len_max=len2;
        k=0;
        for(i=0; i<len_max; i++)
        {
            c[i]=(a[i]+b[i]+k)%10;
            k=(a[i]+b[i]+k)/10;
        }
        if(k!=0)
            c[len_max]=1;
        printf("Case %d:\n",j);
        j++;
        printf("%s + %s = ",str1,str2);
        if(c[len_max]==1)
            printf("%d",c[len_max]);
        for(i=len_max-1; i>=0; i--)
            printf("%d",c[i]);
        printf("\n");
        flag2=1;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值