2011 regional Beijing Site A —— Qin Shi Huang's National Road System

题目:
Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven
kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was
the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other
kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty
---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last
dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang"
means "the first emperor" in Chinese.
Qin Shi Huang undertook gigantic projects,
including the first version of the Great Wall of China, the
now famous city-sized mausoleum guarded by a
life-sized Terracotta Army, and a massive national road
system. There is a story about the road system:
There were n cities in China and Qin Shi Huang
wanted them all be connected by n-1 roads, in order that
he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the
total length of all roads to be minimum,so that the road
system may not cost too many people's life. A daoshi
(some kind of monk) named Xu Fu told Qin Shi Huang
that he could build a road by magic and that magic road
would cost no money and no labor. But Xu Fu could
only build ONE magic road for Qin Shi Huang. So Qin
Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total
length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to
benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the
ratio of A to B) must be the maximum, which A is the total population of the two cites
connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment
connecting two points.
Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
2
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0
< P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The
result should be rounded to 2 digits after decimal point.
Sample Input
241
1 20
1 2 30
200 2 80
200 1 100
31
1 20
1 2 30
2 2 40
Sample Output
65.00
70.00

就是给你N个城市,完全图,求一个比率,两个的城市人口/其他城市相连的代价 ,求这个比率最大。要建立N-1条路。

所以就是相当于,求一棵最小生成树,然后替换掉其中一条边枚举求最大比率。

用到替换边肯定是替换从u->v 路上最大的边,所以先BFS或者DFS求出最小生成树里任意两点最大的边,然后替换掉求比率即可。

用kruskal稍不留神就会TLE,我过不去 = =。。用Prim过的。中间需要记录哪一条是生成树的边。

#include <set>
#include <queue>
#include <stack>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <limits.h>
#include <string.h>
#include <string>
#include <algorithm>
#define MID(x,y) ( ( x + y ) >> 1 )
#define L(x) ( x << 1 )
#define R(x) ( x << 1 | 1 )
#define FOR(i,s,t) for(int i=(s); i<(t); i++)
#define BUG puts("here!!!")
#define STOP system("pause")
#define file_r(x) freopen(x, "r", stdin)
#define file_w(x) freopen(x, "w", stdout)

using namespace std;

const int MAX = 1010;

struct point{
	int x, y;
};
struct TNODE{
	int v;
	double len;
	TNODE *next;
};
TNODE *t[MAX], tnode[MAX*2];
double medge[MAX][MAX];
point p[MAX];
int val[MAX];
int cou;
double map[MAX][MAX];
pair<int,int> pii[MAX];

double disp2p(point &a, point &b)
{
	return sqrt((a.x - b.x)*(a.x - b.x)*1.0 + (a.y - b.y)*(a.y - b.y));	
}
void Add(int u, int v, double l)
{
	tnode[cou].v = v;
	tnode[cou].len = l;
	tnode[cou].next = t[u];
	t[u] = &tnode[cou++];	
}

double Prim(int n)
{
    int used[MAX], i, j, now;
	double sum = 0, dis[MAX], min;  
    
    memset(used, 0, sizeof(used));
    fill(dis, dis+MAX, 1e20);
    
    now = 0; dis[now] = 0; used[now] = 1;
    memset(t, 0, sizeof(t));
    for(i=1; i<n; i++)  
    {  
        for(j=0; j<n; j++)  
            if( !used[j] && dis[j] > map[now][j] )
			{  
                dis[j] = map[now][j];
				pii[j] = make_pair(now, j);			//记录最小边的两个点 
			}  
        min = 1e20;
        for(j=0; j<n; j++)  
            if( !used[j] && dis[j] < min )
				min = dis[now = j];
				 
        sum += min;
        used[now] = 1;
        
        int u = pii[now].first;				// 构造邻接表的生成树,为下面搜索做准备 
        int v = pii[now].second;
        Add(u, v, min);
		Add(v, u, min);		
	}  
    return sum; 
}

bool used[MAX];
int q[MAX];
void BFS(int x)		// 查找一个点在树上到达另一个点的最大边,存入medge数组 
{
	memset(used, 0, sizeof(used));
	int top = 0, end = 1;
	q[0] = x;
	used[x] = true;
	
	while( top < end )
	{
		int now = q[top++];
		TNODE *head = t[now];
		while( head )
		{
			int v = head->v;
			if( !used[v] )
			{
				used[v] = true;
				q[end++] = v;
				double len = head->len;
				medge[x][v] = max(len, medge[x][now]);
			}
			head = head->next;
		}
	}
}
double solve( int n )
{
	FOR(i, 0, n)
	{
		map[i][i] = 0;
		FOR(k, i+1, n)
		{
			double l = disp2p(p[i], p[k]);
			map[i][k] = map[k][i] = l;	
		}
	}
	
	double sum = Prim( n );
	
	FOR(i, 0, n)
		FOR(k, 0, n)
			medge[i][k] = 0;
			
	FOR(i, 0, n)
		BFS(i);

	double ratio = 0;
	FOR(i, 0, n)
		FOR(k, i+1, n)
		{
			int sumval = val[i] + val[k];
			ratio = max(ratio, sumval/(sum - medge[i][k]));
		}
	return ratio;
}

int main()
{
	int ncases, n;
	
	scanf("%d", &ncases);
	
	while( ncases-- )
	{
		scanf("%d", &n);
		cou = 0;
		FOR(i, 0, n)
			scanf("%d%d%d", &p[i].x, &p[i].y, &val[i]);	
		
		double ans = solve( n );

		printf("%.2lf\n", ans);
	}

return 0;
}


评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值