[容易] kruskal 算法并查集实现

题目描述

    In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
    Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle. 

输入:

    The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

输出:

    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

样例输入:
3
1.0 1.0
2.0 2.0
2.0 4.0
样例输出:
3.41
具体代码:

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <cmath>
#include <cstdio>

using namespace std;
const int maxn=100+4;
double X[maxn];
double Y[maxn];
struct Edge
{
    int from,to;
    double dist;
    bool operator < (const Edge& rhs) const
    {
        return dist<rhs.dist;
    }
};
Edge edges[maxn*(maxn-1)/2];
int p[maxn];
int findFather(int x)
{
    return p[x]==x?x:p[x]=findFather(p[x]);
}

int main()
{
    int n;
    cout<<fixed<<setprecision(2);
    while(cin>>n)
    {
        for(int i=0;i<n;++i)
        {
            cin>>X[i]>>Y[i];
        }
        int cnt=0;
        for(int i=0;i<n-1;++i)
        {
            for(int j=i+1;j<n;++j)
            {
                edges[cnt].from=i;
                edges[cnt].to=j;
                edges[cnt].dist=(Y[j]-Y[i])*(Y[j]-Y[i])+(X[j]-X[i])*(X[j]-X[i]);
                ++cnt;
            }
        }
        for(int i=0;i<n;++i)
            p[i]=i;
        sort(edges,edges+cnt);
        double ans=0;
        for(int i=0;i<cnt;++i)
        {
            int pa=findFather(edges[i].from);
            int pb=findFather(edges[i].to);
            if(pa!=pb)
            {
                p[pa]=pb;
                ans+=sqrt(edges[i].dist);
            }
        }
        //printf("%.2lf\n",ans);
        cout<<ans<<endl;
    }
    return 0;
}

[另外] 

1. 如果要判断最小生成树是否存在,只需要看最终选取的边数是否等于结点数-1即可。参考如下代码:(m为结点数)

int sum=0;
for(int i=0;i<n;++i)
        {
            int pa=findFather(edges[i].from);
            int pb=findFather(edges[i].to);
            if(pa!=pb)
            {
                p[pa]=pb;
                ans+=edges[i].dist;
                ++sum;
            }
        }
        //printf("%.2lf\n",ans);
        if(sum==m-1)
            cout<<ans<<endl;
        else
            cout<<"?"<<endl;

2. 第一次使用C++中 cout的格式输出,其实也蛮简单嘛~


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值