[容易] 并查集的优雅实现(实例:求无向图最大连通块结点数)

题目描述

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

输入:

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

输出:

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

样例输入:
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
样例输出:
4
2
具体代码:

#include <iostream>

using namespace std;
const int maxn=10000000+4;
int p[maxn];
int sum[maxn];
inline int findFather(int x)
{
    return p[x]==x?x:p[x]=findFather(p[x]);
}

int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=1;i<=maxn;++i)
        {
            p[i]=i;
            sum[i]=1;
        }
        for(int i=0;i<n;++i)
        {
            int a,b;
            cin>>a>>b;
            int pa=findFather(a);
            int pb=findFather(b);
            if(pa!=pb)
            {
                p[pa]=pb;
                sum[pb]+=sum[pa];
            }
        }
        int maxSum=1;
        for(int i=1;i<=maxn;++i)
        {
            if(p[i]==i)
            {
                maxSum=max(maxSum,sum[i]);
            }
        }
        cout<<maxSum<<endl;
    }
    return 0;
}
[注意]

我们在使用并查集的同时也可以在表示集合的树的根结点保存其它额外信息,并且在集合合并的过程中维护该值,以便于求解
某些集合问题。



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值