UVa - 129 - Krypton Factor

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequence of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called ``easy''. Other sequences will be called ``hard''.

For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:

  • BB
  • ABCDACABCAB
  • ABCDABCD

Some examples of hard sequences are:

  • D
  • DC
  • ABDAB
  • CBABCBA

Input and Output

In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range tex2html_wrap_inline39 , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.

For example, with L = 3, the first 7 hard sequences are:


AB 
ABA 
ABAC 
ABACA 
ABACAB 
ABACABA

As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.

Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be

ABAC ABA
7

Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.

Sample Input

30 3
0 0

Sample Output

ABAC ABCA CBAB CABA CABC ACBA CABA
28

基本思路就是一个字母一个字母的生成,只是每次生成一个需要判定是否满足要求。一种想法就是每增加一个,就判断左右的偶数长度的子串是否满足要求,这样做了很多重复工作。所以每次判定的时候只需要判断后缀偶数长度的子串是否满足要求,然后回溯求解即可。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cctype>
#include <cstring>
#include <string>
#include <sstream>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <stack>
#include <queue>
#include <bitset> 
#include <cassert> 
#include <cmath>
#include <functional>

using namespace std;

int n, L, cnt;
int s[85];

bool dfs(int cur) // 返回false表示已经得到解,不用继续搜索
{
	if (cnt++ == n) {
		for (int i = 0; i < cur; i++) {
			if (i % 64 == 0 && i > 0) { // 每行64个
				cout << endl;
			}
			else if (i % 4 == 0 && i > 0) { // 每4个一个空格
				cout << ' ';
			}
			cout << (char)('A' + s[i]);
		}
		cout << endl << cur << endl;
		return false;
	}

	for (int i = 0; i < L; i++) {
		s[cur] = i;
		bool ok = true;
		for (int j = 1; j * 2 <= cur + 1; j++) { // 长度为j*2的后缀是否满足
			bool equal = true;
			for (int k = 0; k < j; k++) {
				if (s[cur - k] != s[cur - k - j]) { // 检查后一半是否等于前一半
					equal = false;
					break;
				}
			}
			if (equal) { // 前后相等了,不合法
				ok = false;
				break;
			}
		}
		if (ok) {
			if (!dfs(cur + 1)) {
				return false; // 递归搜索,如果已经找到,则退出
			}
		}
	}
}

int main()
{
	ios::sync_with_stdio(false);
	while (cin >> n >> L && n) {
		cnt = 0;
		dfs(0);
	}

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值