UVa - 1347 - Tour

John Doe, a skilled pilot, enjoys traveling. While on vacation, he rents a small plane and starts visiting beautiful places. To save money, John must determine the shortest closed tour that connects his destinations. Each destination is represented by a point in the plane pi = < xiyi > . John uses the following strategy: he starts from the leftmost point, then he goes strictly left to right to the rightmost point, and then he goes strictly right back to the starting point. It is known that the points have distinctx -coordinates.

Write a program that, given a set of n points in the plane, computes the shortest closed tour that connects the points according to John's strategy.

Input 

The program input is from a text file. Each data set in the file stands for a particular set of points. For each set of points the data set contains the number of points, and the point coordinates in ascending order of the x coordinate. White spaces can occur freely in input. The input data are correct.

Output 

For each set of data, your program should print the result to the standard output from the beginning of a line. The tour length, a floating-point number with two fractional digits, represents the result.


Note: An input/output sample is in the table below. Here there are two data sets. The first one contains 3 points specified by their x and y coordinates. The second point, for example, has the x coordinate 2, and the y coordinate 3. The result for each data set is the tour length, (6.47 for the first data set in the given example).

Sample Input 

3 
1 1
2 3
3 1
4 
1 1 
2 3
3 1
4 2

Sample Output 

6.47
7.89

动态规划,主要还是状态的定义,首先题目要求是走过去再走回来,等价命题:两个人同时从最左边的点除法,沿着两条不同的路走到最右边的点。这样就好处理了。

因为输出的格式问题WA了两次,心痛。。。刚开始用了

	cout.setf(ios::fixed);
	cout << setprecision(2) << <span style="font-family: Arial, Helvetica, sans-serif;">dist[1][2] + d[2][1] </span><< endl; // 输出格式注意
然后就出问题,它是先把dist[1][2]和d[2][1]分别变成小数点后两位的精度,然后加起来,直接答案就错误了。。。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cctype>
#include <cstring>
#include <string>
#include <sstream>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <stack>
#include <queue>
#include <bitset> 
#include <cassert> 
#include <cmath>
#include <functional>
#include <iomanip>

using namespace std;

const int maxn = 55;
int n;
double x[maxn], y[maxn], dist[maxn][maxn];
double d[maxn][maxn];
// d(i, j)表示1~max(i, j)全都走过,并且两个人的当前位置是i和j还需要走多长的距离

// 动态规划求解
void solve()
{
	for (int i = n - 1; i >= 2; i--) {
		for (int j = 1; j < i; j++) {
			if (i == n - 1) { // 边界
				d[i][j] = dist[i][n] + dist[j][n];
			}
			else {
				d[i][j] = min(dist[i][i + 1] + d[i + 1][j], dist[j][i + 1] + d[i + 1][i]);
			}
		}
	}
	double ans = dist[1][2] + d[2][1];
	cout.setf(ios::fixed);
	cout << setprecision(2) << ans << endl; // 输出格式注意
}

int main()
{
	while (cin >> n) {
		for (int i = 1; i <= n; i++) {
			cin >> x[i] >> y[i];
		}
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= n; j++) {
				dist[i][j] = sqrt((x[i] - x[j]) * (x[i] - x[j]) + (y[i] - y[j]) * (y[i] - y[j]));
			}
		}
		solve();
	}

	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值