HDU 莫比乌斯反演 1695 GCD


Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
  
  
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
  
  
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).

/*hdu 1695
  题意:
  给出a,b,c,d,k, 求满足a <= x <= b && c <= y <= d && gcd(x,y)=k 的数对(x,y)的对数。
  限制:
  a=c=1; 0 < b,c <= 1e5; (n1,n2) 和 (n2,n1) 算为同种情况
  思路:
  其实是求满足1 <= x <= b/k && 1 <= y <= d/k && gcd(x,y)=1 的 数对(x,y)的对数。
  莫比乌斯反演入门题
  设f(k)为gcd(x,y)=k的数对(x,y)的对数,我们要求的是f(1)
  设F(k)为gcd(x,y)为k的倍数的数对(x,y)的对数,可以想到F(k)=floor(b/k)*floor(d/k),
  由莫比乌斯反演得:
  令lim=min(b/k,d/k)
  f(1)=mu[1]*F(1) + mu[2]*F[2] + ... + mu[lim]*F(lim)
  因为(n1,n2)和(n2,n1)算为同一种情况,所以最后结果还要减掉重复的情况。
 */
#include<stdio.h>
#include<string.h>
#include<math.h>
#include <queue>
#include <iostream>
#include<algorithm>
#define ll long long
using namespace std;
const int INF=0x7fffffff;
const int N=1000000+1;
int prime[N],mu[N],vis[N];
void Moblus()
{   //O(log(n))
    int i,j;
    memset(vis,0,sizeof(vis));
    mu[1]=1;
    int cnt=0;
    for (i=2;i<N;i++)
    {
        if (!vis[i])
        {
            prime[cnt++]=i;
            mu[i]=-1;
        }
        for (j=0;j<cnt&&i*prime[j]<N;j++)
        {
            vis[i*prime[j]]=1;
            if (i%prime[j])
                mu[i*prime[j]]=-mu[i];
            else{
                mu[i*prime[j]]=0;
                break;
            }
        }
    }
}
void getMu()
{  //O(nlog(n))
    int i,j;
    for (i=1;i<N;i++)
    {
        int target=i==1?1:0;
        int delta=target-mu[i];
        mu[i]=delta;
        for (j=i+i;j<N;j+=i)
            mu[i]+=delta;
    }
}
int main()
{
    int i,j,a,b,c,d,k,t,p=0;
    Moblus();
    scanf("%d",&t);
    while (t--)
    {
        p++;
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
        printf("Case %d: ",p);
        if (k==0)
        {
             printf("0\n");
             continue;
        }
        b/=k;
        d/=k;
        if (b>d)
        {
            int temp=b;
            b=d;
            d=temp;
        }
        ll ans1=0;
        for (i=1;i<=b;i++)
            ans1+=(ll)mu[i]*(b/i)*(d/i);
        ll ans2=0;
        for (i=1;i<=b;i++)      //去重
            ans2+=(ll)mu[i]*(b/i)*(b/i);
        ans1-=ans2/2;
        printf("%lld\n",ans1);
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值