[ACM] HDU 1695 GCD (容斥原理)

GCD




Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
  
  
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
  
  
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
 

Source


给定a,b,c,d,k,其中a=1,c=1,问

有多少对gcd(x,y)==k, a<=x<=b   c<=y<=d
且(1,3) (3,1)这样的算作一对,只要保证x<y就可以.


首先缩小范围,另b=b/k,d=d/k
转化成有多少对gcd(x,y)==1。
假设b<d.
那么将d化为 [1,b], [b+1,d]两部分
先求 [1,b]这一部分,gcd(x,y)==1,1<=x<=b, 1<=y<=b
只要对每个数求其欧拉函数,然后累加就可以了。
再求 [b+1,d]这一部分,gcd(x,y)==1, 1<=x<=b ,  b+1<=y<=d
要求x,y互质,对于每一个y,如果x能够被y的一个素因子整除,那么gcd(x,y)肯定不等于1


所以我们先求[1,b]中有多少个数和y不互素,也就是能被y的素因子整除,然后用b减去这个数就是我们
所要求的满足gcd(x,y)==1的数

求得时候用到了容斥原理,加上能被1个素因子整除的,减去两个的,加上三个的,减去四个的.....


#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <stdlib.h>
#include <cmath>
#include <iomanip>
#include <vector>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <cctype>
#define rd(x) scanf("%d",&x)
#define rd2(x,y)  scanf("%d%d",&x,&y)
#define rd3(x,y,z) scanf("%d%d%d",&x,&y,&z)
using namespace std;
typedef long long ll;
const int maxn=1002;
int prime[maxn+1];
void getPrime()
{
    memset(prime,0,sizeof(prime));
    for(int i=2;i<=maxn;i++)
    {
        if(!prime[i])
            prime[++prime[0]]=i;
        for(int j=1;j<=prime[0]&&prime[j]<=maxn/i;j++)
        {
            prime[prime[j]*i]=1;
            if(i%prime[j]==0)
                break;
        }
    }
}

int factor[100][2];
int fatcnt;
int getFactors(int x)
{
    fatcnt=0;
    int tmp=x;
    for(int i=1;prime[i]<=tmp/prime[i];i++)
    {
        factor[fatcnt][1]=0;
        if(tmp%prime[i]==0)
        {
            factor[fatcnt][0]=prime[i];
            while(tmp%prime[i]==0)
            {
                factor[fatcnt][1]++;
                tmp/=prime[i];
            }
            fatcnt++;
        }
    }
    if(tmp!=1)
    {
        factor[fatcnt][0]=tmp;
        factor[fatcnt++][1]=1;
    }
    return fatcnt;
}

const int MAXN=100010;
int euler[MAXN+1];
void getEuler()
{
    memset(euler,0,sizeof(euler));
    euler[1]=1;
    for(int i=2;i<=MAXN;i++)
    {
        if(!euler[i])
            for(int j=i;j<=MAXN;j+=i)
        {
            if(!euler[j])
                euler[j]=j;
            euler[j]=euler[j]/i*(i-1);
        }
    }
}

int t,cas=1;
int a,b,c,d,k;
long long ans;

int cal(int n,int m)//计算1~n里面有多少个数和m互质
{
    getFactors(m);
    int ans=0;
    for(int s=1;s<(1<<fatcnt);s++)//直接枚举二进制位
    {
        int k=0;//重叠几次
        int lcm=1;
        for(int j=0;j<fatcnt;j++)
        {
            if(s&(1<<j))
            {
                k++;
                lcm*=factor[j][0];//因为都是素数,最小公倍数就是他们的乘积
            }
        }
        if(k&1)
            ans+=n/lcm;
        else
            ans-=n/lcm;
    }
    return n-ans;
}

int main()
{
    rd(t);
    getPrime();
    getEuler();
    while(t--)
    {
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
        if(k==0||k>b||k>d)
        {
            printf("Case %d: %d\n",cas++,0);
            continue;
        }
        if(b>d)
            swap(b,d);
        b/=k,d/=k;
        ans=0;
        for(int i=1;i<=b;i++)
            ans+=euler[i];
        for(int i=b+1;i<=d;i++)
            ans+=cal(b,i);
        printf("Case %d: %I64d\n",cas++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值