POJ 1724 ROADS

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find  the shortest path from the city 1 to the city N  that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

这种题目一开始看是最短路,但最终的结果又跟最短路有很大区别,相当于让求的是第k最短路,题目中添加了一个钱币数量的变量,最好想的是用dfs让程序去暴力,找出最终的结果,当然也要进行优化

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
#define ll long long
#define inf 1<<30
const int N=10001;
int head[N],vis[N],cnt,n,m,k,ans;
struct node{
    int e,d,c;
    int next;
};
node p[N];
void add(int a,int b,int d,int c)
{
    p[cnt].e=b;
    p[cnt].c=c;
    p[cnt].d=d;
    p[cnt].next=head[a];
    head[a]=cnt++;
}
void dfs(int cur,int dist,int money)
{
    if (dist>ans)
        return;
    if (cur==n && money>=0 && dist<ans)
        ans=dist;
    for (int i=head[cur];i!=-1;i=p[i].next)
    {
        int temp=p[i].e;
        if (!vis[temp] && money>=p[i].c)
        {
            vis[temp]=1;
            dfs(temp,dist+p[i].d,money-p[i].c);
            vis[temp]=0;
        }
    }
}
int main()
{
    int i,a,b,c,d;
    while (~scanf("%d%d%d",&k,&n,&m))
    {
        cnt=0;
        memset(head,-1,sizeof(head));
        for (i=1;i<=m;i++)
        {
            scanf("%d%d%d%d",&a,&b,&d,&c);
            add(a,b,d,c);
        }
        ans=inf;
        memset(vis,0,sizeof(vis));
        dfs(1,0,k);
        if (ans<inf)
            printf("%d\n",ans);
        else
            printf("-1\n");
    }
    return 0;
}

还有一种是通过优先队列,进行bfs操作,利用优先队列的排列特性,控制好一个钱币变量的问题,然后就能得出最终结果。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
#define ll long long
#define inf 1<<30
const int N=10001;
int cnt,head[N];
int k,m,n;
struct node{
    int id,cost,dis;
    friend bool operator< (node n1,node n2)
    {
        return n1.dis>n2.dis;     //从小到大
    }
};
struct edge{
    int e,dis,cost;
    int next;
};
edge p[N];
void add(int a,int b,int d,int c)
{
    p[cnt].e=b;
    p[cnt].cost=c;
    p[cnt].dis=d;
    p[cnt].next=head[a];
    head[a]=cnt++;
}
void bfs()
{
    int i;
    node cur,next;
    priority_queue<node> Q;

    cur.id=1,cur.dis=0,cur.cost=0;
    Q.push(cur);
    int ans=inf;
    while (!Q.empty())
    {
        cur=Q.top();
        Q.pop();
        if (cur.id==n)
        {
            ans=cur.dis;
            break;
        }
        for (i=head[cur.id];i!=-1;i=p[i].next)
           if (cur.cost+p[i].cost<=k)
        {
            next.cost=cur.cost+p[i].cost;
            next.dis=cur.dis+p[i].dis;
            next.id=p[i].e;
            Q.push(next);
        }
    }
    if (ans<inf)
        printf("%d\n",ans);
    else
        printf("-1\n");
}
int main()
{
    int a,b,c,d,i;
    while (~scanf("%d%d%d",&k,&n,&m))
    {
        cnt=0;
        memset(head,-1,sizeof(head));
        for (i=1;i<=m;i++)
        {
            scanf("%d%d%d%d",&a,&b,&d,&c);
            add(a,b,d,c);
        }
        bfs();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值