poj2395 Kruskal题解(Prim好像过不了)

12 篇文章 0 订阅
12 篇文章 0 订阅

这道题在poj  discuss中有人说Prim做不了,我不信,做了一下,结果真不行,有重边.Kruskal就可以了.

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M.

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

Hint

OUTPUT DETAILS:

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct Way
{
	int a,b,val;
};
Way w[100001];
int f[2001],s[2001],home[2001];
int idx;
int n,m,t,how,a,b,c;
bool com(const Way &a,const Way &b)
{
	return a.val<b.val;
}//排序从小到大
int find(int p)
{
	if(f[p]==p)
		return p;
	int fp=find(f[p]);
	f[p]=fp;
	return fp;//并查集
}
void merge(int a,int b)
{
	int fa=find(a);
	int fb=find(b);
	how--;
	if(s[fa]>s[fb])
		f[fb]=fa,s[fa]+=s[fb];
	else
		f[fa]=fb,s[fb]+=s[fa];//启发式合并
}
int main()
{
	while(scanf("%d%d",&n,&m)==2)
	{
		idx=0;
		how=n;
		for(int i=1;i<=n;i++)
			f[i]=i,s[i]=1;
		for(int i=1;i<=m;i++)
			scanf("%d%d%d",&w[i].a,&w[i].b,&w[i].val);
		sort(w+1,w+m+1,com);//按边排序
		for(int i=1;i<=m;i++)
		{
			if(find(w[i].a)==find(w[i].b))
				continue;
			merge(w[i].a,w[i].b);
			if(how==1)
			{
				printf("%d\n",w[i].val);
				break;
			}
		}
	}
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值