I - FatMouse' Trade (肥猫的罪恶交易)

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains Jii pounds of JavaBeans and requires Fii pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get Jii* a% pounds of JavaBeans if he pays Fii* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers Jii and Fii respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.  
The warehouse has N rooms. The i-th room contains J i i  pounds of JavaBeans and requires F i i  pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J i i* a% pounds of JavaBeans if he pays F i i* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.  
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J i i  and F i i  respectively. The last test case is followed by two -1's. All integers are not greater than 1000.  
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.  
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500








《贪心算法的应用,按单位javabean排序》


#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
using namespace std;
struct Room
{
double j; //房间里含的总javabean
double f; //所需猫食
double ave; //单位交换的javabean
} room[10000];

int cmp(const Room a,const Room b)
{
return a.ave>b.ave;
}

int main()
{
int n,m;


while(cin >> m>>n&& (n!=-1||m!=-1))
{


for(int i=0;i<n;i++)
{
scanf("%lf%lf",&room[i].j,&room[i].f);
room[i].ave=room[i].j/room[i].f;


}

sort(room,room+n,cmp); //单位价值排序

double sum=0;
int i=0;
while(m>0&&i<n)
{
if(room[i].f<m)
{
sum+=room[i].j;
m-=room[i].f; //全部能换走
}
else                                                          //   微笑一定要注意猫粮很多,而猫的仓库很少的情况,不仅仅要判断猫粮完了没,还要判断仓库完了没。
            {
sum+=m*room[i].ave; //只能部分换走
m=0;

}
i++;
}
printf("%.3lf\n",sum);
}
return 0;
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值