FatMouse's Trade(猫鼠交易)

 

1247: FatMouse's Trade

时间限制: 1 Sec  内存限制: 32 MB
提交: 89  解决: 55
您该题的状态:已完成
[提交][状态][讨论版]

题目描述

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 

输入

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

输出

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

样例输入

4 2
4 7
1 3
5 5
4 8
3 8
1 2
2 5
2 4
-1 -1

样例输出

2.286
2.500

 

#include<cstdio>
#include<algorithm>
using namespace std;
struct off
{
    double a;
    double b;
    double c;
}team[1001];
int cmp(off x,off y)
{
    return x.c>y.c;
}
int main()
{
    int m,n;
    while(scanf("%d %d",&m,&n))
    {
        if(m==-1&&n==-1)
        {
            break;
        }
        int i,j;
        for(i=0;i<n;i++)
        {
            scanf("%lf %lf",&team[i].a,&team[i].b);
            team[i].c =team[i].a /team[i].b ;
        }
        sort(team,team+n,cmp); 
        double sum=0;
        for(i=0;i<n;i++)
        {
            if(m>team[i].b)
            {
                m-=team[i].b;
                sum+=team[i].a;
            }
            else
            {
                sum+=m*team[i].c ;
                break;
            }
         } 
         printf("%.3lf\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值