UVA - 10420 List of Conquests

Description

In Act I, Leporello is telling Donna Elvira about his master's long list of conquests:

``This is the list of the beauties my master has loved, a list I've made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.'' (Madamina,ilcatalogo è questo)

As Leporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order, it is very troublesome for him to present his master's conquest to others because he needs to count the number of ``beauties'' by their nationality each time. You are to help Leporello to count.

Input

The input consists of at most 2000 lines, but the first. The first line contains a number n, indicating that there will be n more lines. Each following line, with at most 75 characters, contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.

Output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.

Sample Input

3 
Spain Donna Elvira 
England Jane Doe 
Spain Donna Anna 

Sample Output

England 1 

Spain 2


字母的排序问题

<span style="font-family:Microsoft YaHei;font-size:18px;">#include<iostream>
#include<stdio.h>
#include<string>
#include<stdlib.h>
#include<sstream>
#include<algorithm>


using namespace std;

class Person
{
	public:
	string country;
	string name;


};

Person person[3000];

int comper(Person a,Person b){
	
	if(a.country == b.country)

		return a.name < b.name;
			
			else
				return a.country < b.country;


}

int main(){
	int n1;
	cin >> n1;
	string ck;
	getline(cin,ck);
	string str;
	for(int i = 0; i < n1; i ++){
		getline(cin,str);
			istringstream in(str);
		in >> person[i].country;

	while(!in.eof()){
		string t;
	    in >> t;
	    person[i].name += t;

	
	}	
	}
	sort(person,person + n1, comper);
	string m = person[0].country;
	string n = person[0].name;
	int count = 1;
	for(int i = 1;i < n1; i ++)
	{
		if(m == person[i].country)
		{
		 count ++ ;
		
		}
		else
		{
			cout << m << " " << count <<endl;
			m = person[i].country;
			n = person[i].name;
			count = 1;
		
		}
	
	}
	cout << m << " " << count << endl;
	return 0;
}

</span>


 
  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值