UVA - 10054 The Necklace

My little sister had a beautiful necklace made of colorful beads. Two successive beads in the necklace shared a common color at their meeting point. The figure below shows a segment of the necklace:

But, alas! One day, the necklace was torn and the beads were all scattered over the floor. My sister did her best to recollect all the beads from the floor, but she is not sure whether she was able to collect all of them. Now, she has come to me for help. She wants to know whether it is possible to make a necklace using all the beads she has in the same way her original necklace was made and if so in which order the bids must be put.

Please help me write a program to solve the problem.

Input 

The input contains T test cases. The first line of the input contains the integerT.

The first line of each test case contains an integer N ( $5 \leN \le 1000$) giving the number of beads my sister was able to collect. Each of the next N lines contains two integers describing the colors of a bead. Colors are represented by integers ranging from 1 to 50.

Output 

For each test case in the input first output the test case number as shown in the sample output. Then if you apprehend that some beads may be lost just print the sentence ``some beads may be lost" on a line by itself. Otherwise, printN lines with a single bead description on each line. Each bead description consists of two integers giving the colors of its two ends. For$1 \le i \le N � 1$, the second integer on linei must be the same as the first integer on line i + 1. Additionally, the second integer on lineN must be equal to the first integer on line 1. Since there are many solutions, any one of them is acceptable.

Print a blank line between two successive test cases.

Sample Input 

2
5
1 2
2 3
3 4
4 5
5 6
5
2 1
2 2
3 4
3 1
2 4

Sample Output 

Case #1
some beads may be lost
 
Case #2
2 1
1 3
3 4
4 2
2 2


#include <iostream>
#include <cstring>
#include <cstdio>
#define N  100
using namespace std;

int edge[N][N];
int dge[N];

int judge() {
	for (int i = 0; i < N; i++) {
		if (dge[i] % 2)
			return 0;	
	}
	return 1;
}

void euler(int u) {
	for (int i = 0; i < N;i++) {
		if (edge[u][i]) {
			edge[u][i]--;
			edge[i][u]--;
			euler(i);
			printf("%d %d\n",i,u);
		}	
	}
}

int main() {
	int n, m, u, v; 
	int kase = 0;
	while (scanf("%d",&n) != EOF) {
		while (n--) {
			memset(dge,0,sizeof(dge));
			memset(edge,0,sizeof(edge));
			if(kase)
				printf("\n");
			printf("Case #%d\n",++kase);
			scanf("%d",&m);
			for (int i = 0; i < m; i++) {
				scanf("%d%d",&u ,&v);
				edge[u][v]++;
				edge[v][u]++;
				dge[u]++;
				dge[v]++;	
			}
			if (judge()) {
				for (int i = 0; i < N; i++) 
					if (dge[i])
						euler(i);
			}
			else
				printf("some beads may be lost\n");
		}
	}

	return 0;

}



另外补充欧拉回路的知识点;

    //无向的欧拉回路  
    void euler(int u) {  
        for(int v = 0; v < n; v++) {  
            if(G[u][v] && !vis[u][v]) {  
                vis[u][v] = vis[v][u] = 1;  
                eulur(v);  
                printf("%d %d\n",v,u);  
            }  
        }  
    }  
    //有向的欧拉回路  
    void euler(int u) {  
        for(int v = 0; v < n; v++) {  
            if(G[u][v]) {  
                G[u][v]--;  
                G[v][u]--;  
                eulur(v);  
                printf("%d %d\n",v,u);  
            }  
        }  
    }  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值