UVA - 10305 Ordering Tasks

Problem F

Ordering Tasks

Input: standardinput

Output: standardoutput

Time Limit: 1 second

Memory Limit: 32MB

 

John has n tasks to do.Unfortunately, the tasks are not independent and the execution of one task is onlypossible if other tasks have already been executed.

Input

The input will consist of several instances ofthe problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. nis the number of tasks (numbered from 1to n) and m is the number of direct precedence relations between tasks. Afterthis, there will be m lines with twointegers i and j, representing the fact that task i must be executed before task j.An instance with n = m = 0 willfinish the input.

Output

For each instance,print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3





题意:
拓扑排序的问题

方法一:


#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
#define N 101
using namespace std;

int n, m, k;
int vis[N],b[N];
int a[N][N];

void prin() {
	queue<int> q;
	for (int i = 1; i <= n; i++) 
		if (b[i] == 0)
			q.push(i);
	while (!q.empty()) {
		int t = q.front();
		q.pop();
		k++;
		if (k == n)
			printf("%d\n",t);
		else
			printf("%d ",t);
		for (int i = 1; i <= n; i++) if (a[t][i] && vis[i] == 0) {
				b[i]--;
			if (b[i] == 0) {
				vis[i] = 1;
				q.push(i);	
			}
		
		}	
	}
}

int main() {
	while (scanf("%d%d",&n,&m) != EOF) {
		if (n == 0 && m == 0) 
			break;
		k = 0;
		memset(vis,0,sizeof(vis));
		memset(b,0,sizeof(b));
		memset(a,0,sizeof(a));
		for (int i = 0; i < m; i++) {
			int u, v;
			scanf("%d%d",&u,&v);
			a[u][v]++;
			b[v]++;	
		} 

		prin();
	}
	return 0;

}

方法二:



#include<stdio.h>
#include<string.h>
int n,st[110],top,G[110][110],vis[110];
void dfs(int u)
{
    int v;
    vis[u]=1;
    for(v=1;v<=n;v++)
        if(G[u][v]&&!vis[v])
            dfs(v);
    st[--top]=u;
}
int main()
{
    int i,j,k,m,a,b;
    while(1)
    {
        scanf("%d%d",&n,&m);
        if(n==0)
            break;
        memset(G,0,sizeof(G));
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            G[a][b]=1;
        }
        memset(vis,0,sizeof(vis));
        top=n;
        for(i=1;i<=n;i++)
            if(!vis[i])
                dfs(i);
        for(i=0;i<n;i++)
        {
            if(i)
                printf(" ");
            printf("%d",st[i]);
        }
        printf("\n");
    }
    return 0;    
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值