Hat’s Words (字典树 + 智能指针shared_ptr)

 
 

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 298 Accepted Submission(s): 138
 
Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 
Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 
Sample Input
a
ahat
hat
hatword
hziee
word
 
Sample Output
ahat
hatword
 

#include <stdio.h>
 #include <iostream>
 #include <algorithm>
 #include <cmath>
 #include <vector>
 #include <string.h>
 #include <memory>
 using namespace std;
 string sss[55];
 struct Node {
    int flag = 0;
    shared_ptr<Node> next[50];
 };
 void insert(const shared_ptr<Node>& root, const string& str) {
    shared_ptr<Node> cur(root);
    int i = 0;
    while (i < str.size()) {
        int k = str[i] - 'a';
        if (cur->next[k] == NULL) {
        Node *p = new Node;
        cur->next[k].reset(p);
        cur = cur->next[k];
        } else
        cur = cur->next[k];
        i++;
    }
    cur->flag = 1;
}
 bool search(const shared_ptr<Node>& root,const string& str) {
    shared_ptr<Node> cur(root);
    for (int i = 0; i < str.size(); ++i) {
        if (cur->next[str[i] - 'a'] == NULL)
            return false;
        cur = cur->next[str[i] - 'a'];
    }
    return cur->flag;
 }
 
 int main() {
    shared_ptr<Node> root(new Node);
    int cnt = 0;
    while (cin >> sss[cnt]) {
        insert(root, sss[cnt++]);
    }
    for (int i = 0; i < cnt; ++i) {
    int len = sss[i].size();
    for (int j = 1; j < len - 1; ++j) {
        string str1(sss[i], 0, j);
        string str2(sss[i],j);
        if (search(root, str1) && search(root, str2)){
            cout << sss[i] << endl;
            break;
            }
        }
    }
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值