Intervals (差分约束)

Intervals

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54 Accepted Submission(s): 34
 
Problem Description
You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.

Write a program that:

> reads the number of intervals, their endpoints and integers c1, ..., cn from the standard input,

> computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i = 1, 2, ..., n,

> writes the answer to the standard output
 
Input
The first line of the input contains an integer n (1 <= n <= 50 000) - the number of intervals. The following n lines describe the intervals. The i+1-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50 000 and 1 <= ci <= bi - ai + 1.

Process to the end of file.
 
Output

            The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i = 1, 2, ..., n.
 
Sample Input
5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1
 
Sample Output
6
 
Author
1384
 
具体差分约束是什么东西 算法导论上讲的很清楚

本题重点就是如何建好图的模型
设s[i] 表示集合Z里面的元素在区间[ 0, i ]的个数,left, right 分别表示所有区间里面的最左端和最右端,dis[ ]数组存储源点到某点的最短路。则由题意得限制条件
一 、s[right + 1] -  s[left]  >=  least 即 [left,  right] 区间中个数不小于least
二 、0 <= S[i] - S[i-1] <= 1转换得 s[i + 1] - s[i] >= 0 && s[i] - s[i + 1] >= -1;
然后根据限制条件建图

#include <iostream>
#include <string>
#include <string.h>
#include <algorithm>
#include <cmath>
#include <vector>
#include <stdio.h>
#include <queue>
using namespace std;
const int maxn = 50005;
const int INF = 0x3f3f3f3f;
int left, right;
int n;
struct Node {
    int v, w, next;
}node[maxn * 4];
int head[maxn], dis[maxn], visited[maxn];
int num;
void init() {
    memset(head, -1, sizeof(head));
    memset(dis, -INF, sizeof(dis));
    memset(visited, 0, sizeof(visited));
    num = 0;
    ::left = INF;
    ::right = 0;
}
void add(int u, int v, int w) {
    node[num].v = v;
    node[num].w = w;
    node[num].next = head[u];
    head[u] = num++;
}
int spfa() {
    queue<int> que;
    int cur = ::left;
    dis[cur] = 0;
    que.push(cur);
    visited[cur] = 1;
    while (!que.empty()) {
        int u = que.front();
        que.pop();
        visited[u] = 0;
        for (int i = head[u]; i != -1; i = node[i].next) {
            int v = node[i].v;
            int w = node[i].w;
            if (dis[u] + w > dis[v]) {
                dis[v] = dis[u] + w;
                if (!visited[v]) {
                    visited[v] = 1;
                    que.push(v);
                }
            }
        }
    }
    return dis[::right + 1];
}
int main() {
        //freopen("1.txt", "r", stdin);
    while (cin >> n) {
        init();
        for (int i = 0; i < n; ++i) {
            int a, b, c;
            cin >> a >> b >> c;
            add(a, b + 1, c);
            ::right = max(::right, b);
            ::left = min(::left, a);
        }
            //cout << ::left << "  " << ::right << endl;
        for (int i = ::left; i <= ::right + 1; ++i) {
            add(i, i + 1, 0);
            add(i + 1, i, -1);
        }
        cout << spfa() << endl;
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值