HUD-3308 LCIS 线段树(区间合并)

LCIS

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8005    Accepted Submission(s): 3414


Problem Description
Given n integers.
You have two operations:
U A B: replace the Ath number by B. (index counting from 0)
Q A B: output the length of the longest consecutive increasing subsequence (LCIS) in [a, b].
 

Input
T in the first line, indicating the case number.
Each case starts with two integers n , m(0<n,m<=10 5).
The next line has n integers(0<=val<=10 5).
The next m lines each has an operation:
U A B(0<=A,n , 0<=B=10 5)
OR
Q A B(0<=A<=B< n).
 

Output
For each Q, output the answer.
 

Sample Input
  
  
1 10 10 7 7 3 3 5 9 9 8 1 8 Q 6 6 U 3 4 Q 0 1 Q 0 5 Q 4 7 Q 3 5 Q 0 2 Q 4 6 U 6 10 Q 0 9
 

Sample Output
  
  
1 1 4 2 3 1 2
5
emm题意不说了。。。解释注释里都有。。233333
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <vector>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 100050;
int n, m;
int num[maxn];
struct SegTree {
    int l, r, c;//左右边界以及连续的长度
    int ln, rn;//左右边界的值
    int ls, rs, ms;//左右最大的连续上升子序列的最大值,整个区间的最大值
}tree[maxn << 2];

void push_up(int i) {
    tree[i].ls = tree[i << 1].ls;
    tree[i].rs = tree[i << 1 | 1].rs;
    tree[i].ln = tree[i << 1].ln;
    tree[i].rn = tree[i << 1 | 1].rn;
    tree[i].ms = max(tree[i << 1].ms, tree[i << 1 | 1].ms);
    if (tree[i << 1].rn < tree[i << 1 | 1].ln) {
    //左子树的右边界值小于右子树的左边界值
        if (tree[i << 1].ls == tree[i << 1].c)
            tree[i].ls += tree[i << 1 | 1].ls;
        if (tree[i << 1 | 1].rs == tree[i << 1 | 1].c)
            tree[i].rs += tree[i << 1].rs;
        tree[i].ms = max(tree[i].ms, tree[i << 1].rs + tree[i << 1 | 1].ls);
    }
}

void build(int i, int l, int r) {
    tree[i].l = l;
    tree[i].r = r;
    tree[i].c = r - l + 1;
    if (l == r) {
        tree[i].ms = tree[i].ls = tree[i].rs = 1;
        tree[i].ln = tree[i].rn = num[l];
        return;
    }
    int mid = (l + r) >> 1;
    build(i << 1, l, mid);
    build(i << 1 | 1, mid + 1, r);
    push_up(i);
}

void update(int i, int k, int val) {
    if (tree[i].l == k && tree[i].r == k) {
        tree[i].ln = tree[i].rn = val;
        return;
    }
    int mid = (tree[i].l + tree[i].r) >> 1;
    if (k <= mid)
        update(i << 1, k, val);
    else
        update(i << 1 | 1, k, val);
    push_up(i);
}

int query(int i, int b, int e) {
    if (tree[i].l >= b && tree[i].r <= e)
        return tree[i].ms;
    int mid = (tree[i].l + tree[i].r) >> 1, ans = 0;
    
    if (b <= mid)
        ans = max(ans, query(i << 1, b, e));
    if (e > mid)
        ans = max(ans, query(i << 1 | 1, b, e));
    if (tree[i << 1].rn < tree[i << 1 | 1].ln)
        ans = max(ans, min(mid - b + 1, tree[i << 1].rs) + min(e - mid, tree[i << 1 | 1].ls));
    return ans;
}
void print(int i, int l, int r) {
    if (l == r) {
        cout << tree[i].rn << "  ";
        return ;
    }
    int mid = (l + r) >> 1;
    print(i << 1, l, mid);
    print(i << 1 | 1, mid + 1, r);
}
int main() {
    //freopen("in.txt", "r", stdin);
    ios::sync_with_stdio(false);
    cin.tie(0);
    int t;
    cin >> t;
    while (t--) {
        cin >> n >> m;
        for (int i = 1; i <= n; ++i) {
            cin >> num[i];
        }
        build(1, 1, n);
        char ch[5];
        int a, b;
        for (int i = 0; i < m; ++i) {
            cin >> ch >> a >> b;
            if (ch[0] == 'Q') {
                //题目给的是从0开始的所以都要加1
                cout << query(1, a + 1, b + 1) << endl;
            } else {
                update(1, a + 1, b);
            }
        }
    }
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值