USACO SECTION 1.5 Number Triangles

Number Triangles

Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

          7

        3   8

      8   1   0

    2   7   4   4

  4   5   2   6   5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

PROGRAM NAME: numtri

INPUT FORMAT

The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.

SAMPLE INPUT (file numtri.in)

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

OUTPUT FORMAT

A single line containing the largest sum using the traversal specified.

SAMPLE OUTPUT (file numtri.out)

30

 

/*
ID: conicoc1
LANG: C
TASK: numtri
*/

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int Num[1000][1000];
int Answer[1000][1000];
int a[1000];
int R;
int highest;

int Max(int a,int b)
{
	if(a>b)
		return a;
	else 
		return b;
}


int main()
{
	FILE *fin,*fout;
	fin=fopen("numtri.in","r");
	fout=fopen("numtri.out","w");
	
	fscanf(fin,"%d",&R);
//	printf("%d",R);
	
	int i,j;
	for(i=0;i<R;i++)
	{
		for(j=0;j<=i;j++)
		{
			fscanf(fin,"%d",&Num[i][j]);
			if(j==0)
				Answer[i][j]=Num[i][j]+Answer[i-1][j];
			else
			if(j==i)
				Answer[i][j]=Num[i][j]+Answer[i-1][j-1];
			else
				Answer[i][j]=Num[i][j]+Max(Answer[i-1][j-1],Answer[i-1][j]);
		}
	}	
	
	for(i=0;i<R;i++)
	{
		if(i==0)
			highest=Answer[R-1][i];
		if(Answer[R-1][i]>highest)
			highest=Answer[R-1][i];
	}
	
	fprintf(fout,"%d\n",highest);
	
	return 0;
}


 

传说中的DP+水题?
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值