zoj1514--------------------------Fake Tickets


 

Your school organized a big party to celebrate your team brilliant win in the prestigious, worldfamous ICPC (International Collegiate Poetry Contest). Everyone in your school was invited for an evening which included cocktail, dinner and a session where your team work was read to the audience. The evening was a success - many more people than you expected showed interested in your poetry - although some critics of yours said it was food rather than words that attracted such an audience.

Whatever the reason, the next day you found out why the school hall had seemed so full: the school director confided he had discovered that several of the tickets used by the guests were fake. The real tickets were numbered sequentially from 1 to N (N <= 10000). The director suspects some people had used the school scanner and printer from the Computer Room to produce copies of the real tickets. The director gave you a pack with all tickets collected from the guests at the party's entrance, and asked you to determine how many tickets in the pack had 'clones', that is, another ticket with the same sequence number.

 

Input

The input contains data for several test cases. Each test case has two lines. The first line contains two integers N and M which indicate respectively the number of original tickets and the number of persons attending the party (1 <= N <= 10000 and 1 <= M <= 20000). The second line of a test case contains M integers Ti representing the ticket numbers in the pack the director gave you (1 <= Ti <= N). The end of input is indicated by N = M = 0.


Output

For each test case your program should print one line, containing the number of tickets in the pack that had another ticket with the same sequence number.


Sample Input

5 5
3 3 1 2 4
6 10
6 1 3 6 6 4 2 3 1 2
0 0


Sample Output

1
4

 

用一个数组记录 每个票号是否多次使用,用过一次以上,记作-1,最后查询-1的个数即可

 

代码:

 

#include <iostream>
using namespace std;

int main()
{
	int N,M,x,i,count;
	while(cin>>N>>M&&(N+M)!=0)
	{
		int a[N];
		for(i=0;i<N;i++)
			a[i]=0;
		while(M--)
		{
			cin>>x;
			if(a[x-1]==0)
				a[x-1]=1;
			else if(a[x-1]==1)
				a[x-1]=-1;	
		}
		count=0;
		for(i=0;i<N;i++)
			if(a[i]==-1)
				count++;
		cout<<count<<endl;
	}	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值