zoj1915--------------------Above Average

It is said that 90% of frosh expect to be above average in their class. You are to provide a reality check.


Input

The first line of standard input contains an integer C, the number of test cases. C data sets follow. Each data set begins with an integer, N, the number of people in the class (1 <= N <= 1000). N integers follow, separated by spaces or newlines, each giving the final grade (an integer between 0 and 100) of a student in the class.


Output

For each case you are to output a line giving the percentage of students whose grade is above average, rounded to 3 decimal places.


Sample Input

5
5 50 50 70 80 100
7 100 95 90 80 70 60 50
3 70 90 80
3 70 90 81
9 100 99 98 97 96 95 94 93 91


Sample Output


40.000%
57.143%
33.333%
66.667%
55.556%



代码:

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		int n;
		cin>>n;
		int grade[n];
		double ver=0;
		double per;
		int count=0;
		for(int i=0; i<n; i++)
		{
			cin>>grade[i];
			ver=ver+grade[i];	
		}	
		ver=ver/n;
		for(int i=0; i<n;i++)
		{
			if(grade[i]>ver)
				count++;	
		}
		per=double(count)/n*100;
		printf("%.3lf",per);
		cout<<"%"<<endl;
	}	
	return 0;
		
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值