UVA-70474Where is the Marble?

Raju and Meena love to play with Marbles. They have got a lot ofmarbles with numbers written on them. At the beginning, Raju wouldplace the marbles one after another in ascending order of the numberswritten on them. Then Meena would ask Raju to find the first marblewith a certain number. She would count 1...2...3. Raju gets one pointfor correct answer, and Meena gets the point if Raju fails. After somefixed number of trials the game ends and the player with maximumpoints wins. Today it’s your chance to play as Raju. Being the smartkid, you’d be taking the favor of a computer. But don’t underestimateMeena, she had written a program to keep track how much time you’retaking to give all the answers. So now you have to write a program,which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists beginswith 2 integers: N the number of marbles and Q the number of queries Mina would make. The nextN lines would contain the numbers written on the N marbles. These marble numbers will not comein any particular order. Following Q lines will have Q queries. Be assured, none of the input numbersare greater than 10000 and none of them are negative.Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case.For each of the queries, print one line of output. The format of this line will depend upon whetheror not the query number is written upon any of the marbles. The two different formats are describedbelow:• ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered1, 2, . . . , N.• ‘x not found’, if the marble with number x is not present.Look at the output for sample input for details.

Sample Input4 1235155 213331230 0

Sample OutputCASE# 1:5 found at 4CASE# 2:2 not found3 found at 3

#include <iostream>
#include<cstdio>
#include<cstring>
#include<string.h>
#include<string>
#include<stdio.h>
#include<algorithm>
using namespace std;

int main()
{
    int a[100001];
    int n,i;
    int m;
    int t=1;
    int b;
    int j;
    int f;
    while(scanf("%d%d",&m,&n),m!=0&&n!=0)
    {
        for(i=0;i<m;i++)
            scanf("%d",&a[i]);
        sort(a,a+m);
        printf("CASE# %d:\n",t);
        while(n--)
        {

            scanf("%d",&b);
            for(i=0;i<m;i++)
            {
                f=0;
                if(a[i]==b)
                {
                    f=1;
                    printf("%d found at %d\n",b,i+1);
                    break;
                }
            }
            if(f==0)
                printf("%d not found\n",b);
        }
        t++;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Contents 1 Introduction 1.1 Computing in the Clouds 1.2 Big Ideas 1.3 Why Is This Dierent? 1.4 What This Book Is Not 2 MapReduce Basics 2.1 Functional Programming Roots 2.2 Mappers and Reducers 2.3 The Execution Framework 2.4 Partitioners and Combiners 2.5 The Distributed File System 2.6 Hadoop Cluster Architecture 2.7 Summary 3 MapReduce Algorithm Design 3.1 Local Aggregation 3.1.1 Combiners and In-Mapper Combining 3.1.2 Algorithmic Correctness with Local Aggregation 3.2 Pairs and Stripes 3.3 Computing Relative Frequencies 3.4 Secondary Sorting 3.5 Relational Joins 3.5.1 Reduce-Side Join 64 3.5.2 Map-Side Join 66 3.5.3 Memory-Backed Join 67 3.6 Summary 4 Inverted Indexing for Text Retrieval 4.1 Web Crawling 4.2 Inverted Indexes 4.3 Inverted Indexing: Baseline Implementation 4.4 Inverted Indexing: Revised Implementation 4.5 Index Compression 4.5.1 Byte-Aligned and Word-Aligned Codes 80 4.5.2 Bit-Aligned Codes 82 4.5.3 Postings Compression 84 4.6 What About Retrieval? 4.7 Summary and Additional Readings 5 Graph Algorithms 5.1 Graph Representations 5.2 Parallel Breadth-First Search 5.3 PageRank 5.4 Issues with Graph Processing 5.5 Summary and Additional Readings 6 EM Algorithms for Text Processing 6.1 Expectation Maximization 6.1.1 Maximum Likelihood Estimation 115 6.1.2 A Latent Variable Marble Game 117 6.1.3 MLE with Latent Variables 118 6.1.4 Expectation Maximization 119 6.1.5 An EM Example 120 6.2 Hidden Markov Models 6.2.1 Three Questions for Hidden Markov Models 123 6.2.2 The Forward Algorithm 125 6.2.3 The Viterbi Algorithm 126 6.2.4 Parameter Estimation for HMMs 129 6.2.5 Forward-Backward Training: Summary 133 6.3 EM in MapReduce 6.3.1 HMM Training in MapReduce 135 6.4 Case Study: Word Alignment for Statistical Machine Translation 6.4.1 Statistical Phrase-Based Translation 6.4.2 Brief Digression: Language Modeling with MapReduce 6.4.3 Word Alignment 6.4.4 Experiments 6.5 EM-Like Algorithms 6.5.1 Gradient-Based Optimization and Log-Linear Models 6.6 Summary and Additional Readings 7 Closing Remarks 7.1 Limitations of MapReduce 7.2 Alternative Computing Paradigms 7.3 MapReduce and Beyond

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值