HDU 1023 Train Problem II

As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway. 
Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file. 
Output
For each test case, you should output how many ways that all the trains can get out of the railway. 
Sample Input
1
2
3
10

Sample Output

1
2
5
16796


        
  
Hint
The result will be very large, so you may not process it by 32-bit integers.

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
#define MAX 100
#define BASE 10000
void multiply(int a[],int Max,int b) //大数乘法,注意参数的传递
{
    int i,array=0;
    for (i = Max-1; i >= 0; i--)
    {
        array += b * a[i];
        a[i] = array % BASE; // 数组每一位存放大数的四位数字
        array /= BASE;
    }
}
void divide(int a[], int Max, int b) //模拟大数除法
{
    int i, div = 0;
    for (i = 0; i < Max; i++)
    {
        div = div * BASE + a[i];
        a[i] = div / b;
        div %= b;
    }
}
int main()
{
    int a[101][MAX],i, n;
    memset(a[1],0,MAX*sizeof(int));
    for (i=2, a[1][MAX-1] = 1; i < 101; i++) // 高坐标存放大数低位
    {
        memcpy(a[i], a[i-1], MAX * sizeof(int));      //h[i] = h[i-1];
        multiply(a[i], MAX, 4 * i - 2);               //h[i] *= (4*i-2);
        divide(a[i], MAX, i + 1);                  //h[i] /= (i+1);
    }
    while (cin >> n)
    {
        for (i = 0; i < MAX && a[n][i] == 0; i++); //去掉数组前为0的数字。
        cout << a[n][i++];             //输出第一个非0数
        for (; i < MAX; i++)
        {
            printf("%04d",a[n][i]);       //输出后面的数,并每位都保持4位长度!(32767)
        }
        cout << endl;
    }
    return 0;
}


自己并不会写这道题,参考了大佬们的博客,专门讲卡特兰数的 点击打开链接



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值