Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
————————————————
思路:模拟压栈和出栈的顺序
给num从1开始压栈,要判断的序列a[i],如果比num大,就一直吧num压栈,然后++
如果栈满了,代表不行.然后弹出栈顶元素和序列元素判断是否相等,不相等
就是false;
#include<stdio.h>
#include<iostream>
using namespace std;
typedef struct stack *Stack;
struct stack
{
int data[1000];
int size;
int top;
};
Stack createStack()
{
Stack S = new stack;
S->size = 0;
S->top = -1;
return S;
}
void push(Stack S, int x)
{
S->data[++S->top] = x;
S->size++;
}
int pop(Stack S)
{
S->size--;
return S->data[S->top--];
}
int isEmpty(Stack S)
{
return S->size == 0;
}
int main()
{
int M, N, K;
scanf("%d %d %d", &M, &N, &K);
int *a = new int[N];
for (int i = 0; i < K; i++)
{
int flag = 1;
Stack S = createStack();
for (int j = 0; j < N; j++){
scanf("%d", &a[j]);
}
int num = 1;
for (int k = 0; k < N; k++){
//开始判断
//序列中的数比还没压入的第一个要大,就一直压入直到,num>a[k] 或者栈满了,flag置为0
while (num <= a[k]){
if (S->size<M)
push(S, num++);
else {
flag = 0;
break;
}
}
//弹出和序列中的数比较
if (a[k] != pop(S))
{
flag = 0;
break;
}
}
if (flag){
printf("YES\n");
}
else printf("NO\n");
}
}