A -KIDx's Pagination(练功底)

本文介绍了KIDx为ACdream设计的分页系统,讨论了分页规则和特殊情况的处理,包括当前页按钮禁用、首尾页特殊处理等。在实现过程中,作者提醒注意1 1 1特例,以免造成输出错误。并分享了一段简洁的解决方案代码。
摘要由CSDN通过智能技术生成

好吧,不得不承认自己还是不够好,因为一个特例我竟然找了4个小时的debug,唉,果然陷进去了。

如题:

C - KIDx's Pagination

Crawling in process...Crawling failedTime Limit:1000MS    Memory Limit:64000KB    64bit IO Format:%lld & %llu

Description

One Day, KIDx developed a beautiful pagination for ACdream. Now, KIDx wants you to make another one.

The are n pages in total.
The current page is cur.
The max distance to current page you can display is d.

Here are some rules:

  • The cur page button is disabled.
  • If cur page is the first page, the button "<<" should be disabled.
  • If cur page is the last page, the button ">>" should be disabled.
  • If the button "x" is disabled, print "[x]"; else print "(x)".
  • You should not display the "..." button when there is no hidden page.

You can assume that the button "..." is always disabled.

Input

There are multiple cases.      
Ease case contains three integers n, cur, d.      
1 ≤ n ≤ 100.
1 ≤ cur ≤ n.
0 ≤ d ≤ n.

Output

For each test case, output one line containing "Case #x: " followed by the result of pagination.     

Sample Input

10 5 2
10 1 2

Sample Output

Case #1: (<<)[...](3)(4)[5](6)(7)[...](>>)
Case #2: [<<][1](2)(3)[...](>>)

Hint

Case 1:

Case 2:

 

就是类似于格式转换的东西,我的代码写的比较水,就是一种种分情况去写。

在这里,我只想说,不要忘了 1 1 1 的那组特例,那是输出 [<<][1][>>]的,我变成了[<<][1](>>) ; 所以导致一直WA,我还一直在检查下面的,还以为下面的代码错误。

#include<stdio.h>
int main(){
	int n,cur,d,i,j,k,l,m=1;
	while(scanf("%d%d%d",&n,&cur,&d)!=EOF){
		printf("Case #%d: ",m++);
		//太可恶了,竟然少判断了一组样例; 
		if(cur == 1 && cur == n) {
            printf("[<<][1][>>]\n");
            continue;
        }
		if(cur==1){
			printf("[<<][1]");
			if(1+d<n){
				for(i=1;i<=d;i++)
					printf("(%d)",1+i);
				printf("[...](>>)");
			}
			else {
				for(i=cur+1;i<=n;i++)
					printf("(%d)",i);
				printf("(>>)"); 
			}
		}
		else if(cur!=1 && cur!=n){
			if(cur-1-d>0){
				printf("(<<)[...]");
				for(i=1;i<=d;i++)
					printf("(%d)",cur-1-d+i);
			}
			else{
				printf("(<<)");
				for(i=1;i<cur;i++)
					printf("(%d)",i);
			}
			printf("[%d]",cur);
			if(n-cur<=d){
				for(i=cur+1;i<=n;i++)
					printf("(%d)",i);
				printf("(>>)");
			}
			else {
				for(i=1;i<=d;i++)
					printf("(%d)",cur+i);
				printf("[...](>>)");
			}	
		}
		else if(cur==n){
			if(cur-1-d>0){
				printf("(<<)[...]");
				for(i=0;i<d;i++)
					printf("(%d)",cur-d+i);
			}
			else{
				printf("(<<)");
				for(i=1;i<cur;i++)
					printf("(%d)",i);
			}
			printf("[%d]",cur);
			printf("[>>]");
		}
		printf("\n");
	}
}


 

 

从网上学习的大神的代码(思路是差不多的,但是比我要简洁):

#include <iostream>
#include <cstdio>
 
using namespace std;
 
int main()
{
    int n,cur,d,tp,cnt = 0;
    //freopen("in.txt","r",stdin);
    while(~scanf("%d %d %d",&n,&cur,&d))
    {
        printf("Case #%d: ",++cnt);
        if(cur != 1) printf("(<<)");
        else printf("[<<]");
        if(cur - d > 1) printf("[...]");
        if(cur - d < 1) tp = 1;
        else tp = cur - d;
        for(int i = tp; i < cur && i >= 1; i++)
            printf("(%d)",i);
        printf("[%d]",cur);
        for(int i = cur + 1; i <= cur + d && i <= n; i++)
            printf("(%d)",i);
        if(cur + d < n) printf("[...]");
        if(cur != n) printf("(>>)");
        else printf("[>>]");
        puts("");
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值