POJ 3071 Football 【概率DP】

Football

Football
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3734 Accepted: 1908

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.


题意:这个题是给你一个2^N的一个概率矩阵p , p[i][j]用来表示第i队赢第j队的概率,足球比赛是根据编号由小到大来两两比赛的,问你最有可能最后赢的队伍编号。

分析:队伍两两之间进行比赛,直到得到Winner,这个过程是需要N层比赛的【我想不出什么高级的词汇了,就用层来说吧,语文不好,不要嘲笑~】,每一层有若干双 队伍 同时进行比赛。然后是根据编号两两比赛的,这个时候不妨画出一个图出来,我们可以发现,这就是一个二叉树嘛。

首先,设状态 dp[i][j] 表示第i层比赛第j号队伍赢的概率。

然后,设状态转移方程:dp[i][j] = dp[i-1][j] * ∑(dp[i-1][k]*p[j][k]),ps:k∈(二叉树上(i,j)除了(i-1,j)的另外一个子节点以下的所有叶子节点的编号),说得确实有点拗口,但是只要画出图来,就非常好理解。

接下来,考虑边界情况,显然dp[0][j] = 0,或者说dp[1][j] = p[j][(j-1)^1+1]   【另外一种写法是dp[i][j] = p[j][j&1?j+1:j-1],用哪种凭个人喜好吧】,j∈(1,1<<N)。

最后,只需要遍历所有dp[N][j] ,j∈(1,1<<N),求最大的概率即可。

/**
 *  Memory:444KB    Time:79ms
 *  Author:__Xiong  2015/7/27
 */
#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 7+1;
const int maxm = (1<<maxn);
int N,M,ans;
double pMax,p[maxm][maxm],dp[maxn][maxm];
int main()
{
    //freopen("input.in","r",stdin);
    while(~scanf("%d",&N))
    {
        if(N == -1) break;
        M = (1<<N);
        for(int i = 1; i <= M; i++)
        {
            for(int j = 1; j <= M; j++)
            {
                scanf("%lf",&p[i][j]);
            }
        }
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= N; i++)
        {
            for(int j = 1; j <= M; j++)
            {
                if(i == 1)
                {
                    dp[1][j] = p[j][j&1?j+1:j-1];
                    continue;
                }
                for(int k = 1; k <= M; k++)
                {
                    int a = (j-1)>>(i-1),b = (k-1)>>(i-1);
                    if(a&1) a--;
                    else a++;
                    if(a == b)
                        dp[i][j] += dp[i-1][j]*dp[i-1][k]*p[j][k];
                }
            }
        }
        pMax = 0;
        ans = 0;
        for(int i = 1; i <= M; i++)
        {
            if(pMax < dp[N][i])
            {
                ans = i;
                pMax = dp[N][i];
            }
        }
        printf("%d\n",ans);

    }
    return 0;
}

另外,挂上基神的代码吧。

// 亲测:Memory:1080KB     Time:79ms
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MX = 150 + 5;
#define For(i,x,y) for(int i=x;i<=y;i++)
#define Mem(x,y) memset(x,y,sizeof(x))
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define root 1,n,1
int n;
double A[MX][MX];
double dp[MX << 2][MX];
void solve(int l, int r, int rt)
{
    if(l == r)
    {
        dp[rt][l] = 1;
        return;
    }
    int m = (l + r) >> 1;
    solve(lson);
    solve(rson);
    For(x, l, r)
    {
        if(x <= m)
        {
            For(i, m + 1, r)
            {
                dp[rt][x] += dp[rt << 1 | 1][i] * A[x][i];
            }
            dp[rt][x] *= dp[rt << 1][x];
        }
        else
        {
            For(i, l, m)
            {
                dp[rt][x] += dp[rt << 1][i] * A[x][i];
            }
            dp[rt][x] *= dp[rt << 1 | 1][x];
        }
    }
}
int main()
{
    //freopen("input.in", "r", stdin);
    int n;
    while(~scanf("%d", &n), n >= 0)
    {
        Mem(dp, 0);
        n = 1 << n;
        For(i, 1, n)
        {
            For(j, 1, n)
            {
                scanf("%lf", &A[i][j]);
            }
        }
        solve(root);
        double Max = 0;
        int ans;
        For(i, 1, n)
        {
            if(dp[1][i] > Max)
            {
                Max = dp[1][i];
                ans = i;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值