【poj 2411】Mondriaan's Dream 状态压缩DP

34 篇文章 0 订阅
23 篇文章 0 订阅

Mondriaan’s Dream

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 14345 Accepted: 8273

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!
Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.
Sample Input
1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output
1
0
1
2
3
5
144
51205

Source

Ulm Local 2000
这里写图片描述

题目链接http://poj.org/problem?id=2411

题意
经典的铺砖块问题;

思路
1.《=11的数据范围–》状态压缩DP
递推式:

dp[i]+=tmp[j];

2.滚动数组dp[i]与前一行达到i状态的方案数

代码2:()dfs版

#include<iostream>
#include<string.h> 
using namespace std;
long long  f[12][1<<12];//fullfil level i,the imfactto sta   ; target f[m][0];
int n,m;
int num=0;
int F1[1<<23];
int F2[1<<23];
void dfs(int i,int fromm,int too)
{
    if(i>n) return;
    if(i==n)   
    {   
    num++;  
    F1[num]=fromm;
    F2[num]=too;    
    }
    dfs(i+1,(fromm<<1)+1,too<<1);
    dfs(i+1,fromm<<1,(too<<1)+1);
    dfs(i+2,fromm<<2,too<<2);
}
int main()
{
    while(cin>>n>>m)
    {  
    if(n==0&&m==0)
    return 0;
    num=0;
    memset(f,0,sizeof(f));

    f[0][0]=1;
    dfs(0,0,0);
    for(int i=0;i<=m-1;i++)
      for(int j=1;j<=num;j++)
          {
            f[i+1][F2[j]]+=f[i][F1[j]];
          }


   cout<<f[m][0]<<endl;

    }
    }



//for(int i=0;i<m;i++)
   //for(int j=0;j<=(1<<n-1);j++)
      // {
     // 
     // f[i+1][k]+=f[i][j];
       // }

代码:dp

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define M (1<<11)+10
long long tmp[M];
long long  dp[M];
int n,m;
bool mark[M];
long long  b[13];
bool C(int x)
{
    while(x)
    {
        if(x&1)
        {
            x>>=1;
            if(!(x&1)) return 0//第j列是1则第j+1列必须是1 
            x>>=1;
        }
        else x>>=1;
    }
    return 1;
}
void init()
{
    memset(mark,0,sizeof(mark));
    memset(tmp,0,sizeof(tmp));
    for(int i=0;i<b[m];i++)
    if(C(i))
    tmp[i]=1,mark[i]=1;



}
void solve()
{
    for(int k=2;k<=n;k++)
    {
        for(int i=0;i<b[m];i++)
        {
            dp[i]=0;
            for(int j=0;j<b[m];j++)
            {
                if((i|j)!=b[m]-1) continue;
                if(!mark[i&j]) continue;
                dp[i]+=tmp[j];
            }
        }
        for(int i=0;i<b[m];i++) tmp[i]=dp[i];
    }
    printf("%lld\n",tmp[b[m]-1]);

}
int main()
{

    b[0]=1;
    for(int i=1;i<12;i++) b[i]=b[i-1]*2;
    while(scanf("%d%d",&n,&m))
    {
        if(!n&&!m) r``
turn 0;
        if(m>n) swap(n,m);
        init();
        solve();
    }


} 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值