PAT1020. Tree Traversals (25)(已知中序后序求层序)

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2



已知中序后序求层序


#include<iostream>
#include<algorithm>
#include<string>
#include<queue>

using namespace std;

struct tree
{
    int data;
    tree *l, *r;
};

tree *create_tree(int n, int *a, int *b)
{
    tree *root;
    if(!n)
        return NULL;
    root = new tree;
    root->data = a[n-1];
    int t;
    for(int i=0;i<n;++i)
        if(b[i] == root->data)
        {
            t = i;
            break;
        }
    root->l = create_tree(t, a, b);
    root->r = create_tree(n-t-1, a+t, b+t+1);
    return root;
}

void level_order(tree *root)
{
    queue <int> que;
    tree *p[1010];
    int rear=0, frot=0;
    if(root)
    {
        que.push(root->data);
        p[rear++]=root;
    }
    while(rear>frot)
    {
        root=p[frot++];
        if(root->l)
        {
            que.push(root->l->data);
            p[rear++]=root->l;
        }
        if(root->r)
        {
            que.push(root->r->data);
            p[rear++]=root->r;
        }
    }
    while(!que.empty())
    {
        que.size() == 1?cout<<que.front()<<endl:cout<<que.front()<<" ";
        que.pop();
    }
}

int main()
{
    ios::sync_with_stdio(false);
    int n;
    while(cin>>n)
    {
        int *a = new int [n];
        int *b = new int [n];
        for(int i=0;i<n;++i)
            cin>>a[i];
        for(int i=0;i<n;++i)
            cin>>b[i];
        tree *root;
        root = create_tree(n, a, b);
        level_order(root);

    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

西杭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值