HDU 2303 The Embarrassed Cryptographer

The Embarrassed Cryptographer

Problem Description
The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100 and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output
For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.

Sample Input
  
  
143 10 143 20 667 20 667 30 2573 30 2573 40 0 0
 
Sample Output
   
   
GOOD BAD 11 GOOD BAD 23 GOOD BAD 31

题意:输入有多组,当都为零结束,前一个是个大数,好大好大,10的100次方,后一个是个整数,求小于这个整数的素数是否有前面大数的因数,找出满足条件的最小的那个,如果没有,输出GOOD。

素数筛选法给素数打一个表,枚举素数,再通过反复取余算出与大数的余数是否为零。

#include<stdio.h>
#include<string.h>
int p[1000001];
bool a[1000001];
int k=0;
void prime()
{
    int i,j;
    k=0;
    for(i=0;i<1000001;i++)
    a[i]=1;
    for(i=2;i<1000001;i++)
    {
        if(a[i])
        p[k++]=i;
        j=i*i;
        while(i<1000&&j<1000000)
        {
            a[j]=0;
            j+=i;
        }
    }
}
bool mod(char *n,int m)
{
    int i,end=0;
    for(i=0;n[i];i++)
    end=(end*10+n[i]-'0')%m;
    return end;
}

int main()
{
    char n[101];
    int i,j,m;
    prime();
    while(~scanf("%s%d",n,&m))
    {
        if(m==0)
        break;
        int e=0;
        for(i=0;i<k&&p[i]<m;i++)
        {
            if(mod(n,p[i])==0)
            {
                e=1;
                break;
            }
        }
        if(e==0)
        printf("GOOD\n");
        else
        printf("BAD %d\n",p[i]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值