POJ 2773 Happy 2006 欧拉函数


Happy 2006
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 8940 Accepted: 2983

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006. 

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order. 

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5

Source


给你m和k,求第k个与m互质的数。
在1~m之间有phi[m](phi[m]是m的欧拉函数)个数与m互质,而在m+1~2*m之间也有phi[m]个数与m互质,且在n*m+1~(n+1)*m之间也有phi[m]个数与m互质,并且这phi[m]个数与在1~m之间的phi[m]个数是相互对应的。
因此只要求出第k/phi[m]个区间,然后在这个区间枚举第k个数就可以。当然此方法的时间复杂度不是很优化,不过比较易懂。
//4300K	1594MS
#include<stdio.h>
#include<string.h>
#define M 1000007
int phi[M];
void getphi()//得到欧拉函数
{
    memset(phi,0,sizeof(phi));
    phi[1]=1;
    for(int i=2;i<M;i++)
    {
        if(!phi[i])
            for(int j=i;j<M;j+=i)
            {
                if(!phi[j])
                    phi[j]=j;
                phi[j]=phi[j]/i*(i-1);
            }
    }
}
int gcd(int a,int b)
{
    if(!b)return a;
    return gcd(b,a%b);
}
int main()
{
    int m,k;
    getphi();
    while(scanf("%d%d",&m,&k)!=EOF)
    {
        int num=k/phi[m];
        if(k%phi[m]==0)num--;
        k=k-num*phi[m];//在第num个区间求第k个
        num=num*m+1;//求在第num个区间的第一个数
        int flag;
        for(int i=num;k!=0;i++)//枚举求第k个与m互质的数
            if(gcd(i,m)==1)
            {
                flag=i;
                k--;
            }
        printf("%d\n",flag);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值