Couple doubi(费马小定理或打表找规律+简单博弈)

181 篇文章 0 订阅
79 篇文章 0 订阅


Link:http://acm.hdu.edu.cn/showproblem.php?pid=4861

Couple doubi

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1434    Accepted Submission(s): 993


Problem Description
DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.
 

Input
Multiply Test Cases. 
In the first line there are two Integers k and p(1<k,p<2^31).
 

Output
For each line, output an integer, as described above.
 

Sample Input
  
  
2 3 20 3
 

Sample Output
  
  
YES NO
 

Author
FZU
 

Source
 




/*附上打表找规律代码: 
#include<stdio.h>
#include<math.h>
int main ()
{
   int i ,j ,sum;
   printf("9 3\n");
   for(i = 1 ;i <= 9 ;i ++)
   {
      sum = 0;
      for(j = 1 ;j < 3 ;j ++)
      sum = sum + int (pow(j * 1.0 ,i * 1.0)) % 3;
      printf("%d " ,sum % 3);
   }
   printf("\n2 3\n");
   for(i = 1 ;i <= 2 ;i ++)
   {
      sum = 0;
      for(j = 1 ;j < 3 ;j ++)
      sum = sum + int (pow(j * 1.0 ,i * 1.0)) % 3;
      printf("%d " ,sum % 3);
   }
   printf("\n9 2\n");
   for(i = 1 ;i <= 9 ;i ++)
   {
      sum = 0;
      for(j = 1 ;j < 2 ;j ++)
      sum = sum + int (pow(j * 1.0 ,i * 1.0)) % 2;
      printf("%d " ,sum % 2);
   }
   printf("\n10 3\n");
   for(i = 1 ;i <= 10 ;i ++)
   {
      sum = 0;
      for(j = 1 ;j < 3 ;j ++)
      sum = sum + int (pow(j * 1.0 ,i * 1.0)) % 3;
      printf("%d " ,sum % 3);
   }
   
   printf("\n10 5\n");
   for(i = 1 ;i <= 10 ;i ++)
   {
      sum = 0;
      for(j = 1 ;j < 5 ;j ++)
      sum = sum + int (pow(j * 1.0 ,i * 1.0)) % 5;
      printf("%d " ,sum % 5);
   }
   
   printf("\n10 7\n");
   for(i = 1 ;i <= 10 ;i ++)
   {
      sum = 0;
      for(j = 1 ;j < 7 ;j ++)
      sum = sum + int (pow(j * 1.0 ,i * 1.0)) % 7;
      printf("%d " ,sum % 7);
   }
   
    printf("\n10 11\n");
   for(i = 1 ;i <= 10 ;i ++)
   {
      sum = 0;
      for(j = 1 ;j < 11 ;j ++)
      sum = sum + int (pow(j * 1.0 ,i * 1.0)) % 11;
      printf("%d " ,sum % 11);
   }
   
   getchar();
}*/
/*编程思想:多试几个很容易可以发现规律。。。只有在p-1的倍数时有非0元素存在。
那么由于是博弈,大家每次肯定都是选那个比较大的数,所以,若是 k/(p-1)为奇数则先手必胜,否则平局*/
//AC CODE: 
#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    int k, p;
    while(~scanf("%d%d", &k, &p))
    {
        if((k/(p-1))%2==1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值