HDU 2838 Cow Sorting(树状数组求逆序数)

传送门:点击打开链接

Cow Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3599    Accepted Submission(s): 1256


Problem Description
Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.
 

Input
Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.
 

Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
 

Sample Input
  
  
3 2 3 1
 

Sample Output
  
  
7
Hint
Input Details Three cows are standing in line with respective grumpiness levels 2, 3, and 1. Output Details 2 3 1 : Initial order. 2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).

题意是给定一组无序的数,要求重新排序,只能相邻的交换,交换的价值是两者的和,求最后的交换代价。

luo的树状数组求逆序数模板题啊,硬生生的直接套模板呗。


代码实现:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>

using namespace std;
const int maxn=1e5+5;

int map[maxn],ans[maxn];
long long s[maxn];
int n;

int lowbit(int x)
{
	return x&(-x);
}

void update(int x)
{
	int d=x;
	while(x<=n)
	{
		ans[x]++;
		s[x]+=d;
		x+=lowbit(x);
	}
}

long long add(int x)
{
	long long sum=0;
	while(x)
	{
		sum+=s[x];
		x-=lowbit(x);
	}
	return sum;
}

int sum(int x)
{
	int sum=0;
	while(x)
	{
		sum+=ans[x];
		x-=lowbit(x);
	}
	return sum;
}

//以上均是树状数组求逆序数模板,以下均是数据输入与输出 

int main()
{
	int t,k,i;
	while(scanf("%d",&n)!=EOF)
	{
		memset(ans,0,sizeof(ans));
		memset(s,0,sizeof(s));
		long long ans1=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&map[i]);
			update(map[i]);
			k=sum(map[i]);
			t=i-k;
			if(t!=0)
			{
				ans1+=(long long)map[i]*t;
                ans1+=add(n)-add(map[i]);
			}
		}
		printf("%lld\n",ans1);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值