uva 208 - Firetruck

 Firetruck 

The Center City fire department collaborates with the transportation department to maintain maps of the city which reflects the current status of the city streets. On any given day, several streets are closed for repairs or construction. Firefighters need to be able to select routes from the firestations to fires that do not use closed streets.

Central City is divided into non-overlapping fire districts, each containing a single firestation. When a fire is reported, a central dispatcher alerts the firestation of the district where the fire is located and gives a list of possible routes from the firestation to the fire. You must write a program that the central dispatcher can use to generate routes from the district firestations to the fires.

Input

The city has a separate map for each fire district. Streetcorners of each map are identified by positive integers less than 21, with the firestation always on corner #1. The input file contains several test cases representing different fires in different districts.

  • The first line of a test case consists of a single integer which is the number of the streetcorner closest to the fire.
  • The next several lines consist of pairs of positive integers separated by blanks which are the adjacent streetcorners of open streets. (For example, if the pair 4 7 is on a line in the file, then the street between streetcorners 4 and 7 is open. There are no other streetcorners between 4 and 7 on that section of the street.)
  • The final line of each test case consists of a pair of 0's.

Output

For each test case, your output must identify the case by number (CASE #1, CASE #2, etc). It must list each route on a separate line, with the streetcorners written in the order in which they appear on the route. And it must give the total number routes from firestation to the fire. Include only routes which do not pass through any streetcorner more than once. (For obvious reasons, the fire department doesn't want its trucks driving around in circles.)

Output from separate cases must appear on separate lines.

The following sample input and corresponding correct output represents two test cases.

Sample Input

6
1 2
1 3
3 4
3 5
4 6
5 6
2 3
2 4
0 0
4
2 3
3 4
5 1
1 6
7 8
8 9
2 5
5 7
3 1
1 8
4 6
6 9
0 0

Sample Output

CASE 1:
1 2 3 4 6
1 2 3 5 6
1 2 4 3 5 6
1 2 4 6
1 3 2 4 6
1 3 4 6
1 3 5 6
There are 7 routes from the firestation to streetcorner 6.
CASE 2:
1 3 2 5 7 8 9 6 4
1 3 4
1 5 2 3 4
1 5 7 8 9 6 4
1 6 4
1 6 9 8 7 5 2 3 4
1 8 7 5 2 3 4
1 8 9 6 4
There are 8 routes from the firestation to streetcorner 4.
   开始无脑直接回溯TLD,想记忆化搜索感觉实现麻烦还是会超时,看到很多剪枝办法,可以dfs预处理找出起点和终点连通的点,然后在uva电子版里看到一个做法,英文的
用的floyd-warshall算法来剪枝,初始化连通边为1不连通的为一个值INF,然后floyd之后,不连通的2点边值就是INF,这样回溯的时候,每次dfs一个新节点,不仅要判断是否访问过这个这个点,这个点和上个点是否连通,再加上这个点是否能到终点; 用这个方法0.004sAC
#include<stdio.h>
#include<string.h>
#define INF 999999
int t=0,max,sum,fire,map[30][30],way[30],visit[30],a[30][30];// map保存连点是否直接连通,a保存两点之间能否到达
int dfs(int x,int num)
{int i,j,k,f;
 if (x==fire)
 {printf("1 ");
  for (i=1;i<num-1;i++)
  printf("%d ",way[i]);
  printf("%d\n",fire);
  ++sum;
  return 0;
 }
 for (i=1;i<=max;i++)
 {
  if ((visit[i]==0)&&(map[x][i]==1)&&(a[fire][i]!=INF))
  {way[num]=i;
   visit[i]=1;
   dfs(i,num+1);
   visit[i]=0;
  }
 }
};
int main()
{int i,j,k,x,y;
 while (scanf("%d",&fire)!=EOF)
 {++t; max=0;
  memset(way,0,sizeof(visit));
  for (i=1;i<=21;i++)
  for (j=1;j<=21;j++)
  {map[i][j]=INF;a[i][j]=INF;}
  while (scanf("%d%d",&x,&y),x+y)
  {if (x>max) max=x;
   if (y>max) max=y;
   map[x][y]=1; map[y][x]=1;
   a[x][y]=1; a[y][x]=1;
  }
  for (k=1;k<=max;k++)
  for (i=1;i<=max;i++)
  for (j=1;j<=max;j++)
  if (a[i][k]+a[k][j]<a[i][j]) a[i][j]=a[i][k]+a[k][j];
  visit[1]=1; sum=0;
  printf("CASE %d:\n",t);
  dfs(1,1);
  printf("There are %d routes from the firestation to streetcorner %d.\n",sum,fire);
 }
 return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值