杭电1050 贪心+不相交区间

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30286    Accepted Submission(s): 9938


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
  
  
10 20 30
 

题意:一共四百个房间,南北各两百个房间,每个房间都有桌子,因为会议需要,要把指定房间的桌子搬到另一个指定房间。但是走廊上只能同时搬一张桌子,因此给的房间位置如果有交叉只能等到下一轮搬。每一轮要十分钟,求最少需要多少分钟能把要求搬得桌子搬完。

思路:贪心。(刘汝佳紫书上的区间相关问题)一开始是按照终点排序的,一直WA;后来索性换成起点排,AC。后来想了一下,如果按终点排,不相交区间之间留的间隙太大了,会忽略一些情况,而用起点排序则可以有效使区间间隙减小。


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define M(x,y) memset(x,y,sizeof(x))
using namespace std;
int n,t;
struct xy
{
    int x;
    int y;
    bool flag;
}a[205];
bool cmp(xy xx,xy yy)
{
    return xx.x<yy.x;
}
int main()
{
    //freopen("D://in.txt","r",stdin);
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            int aa,bb;
            scanf("%d %d",&aa,&bb);
            if(aa<bb)
            {
                a[i].x=aa/2+aa%2;
                a[i].y=bb/2+bb%2;
            }
            else
            {
                a[i].x=bb/2+bb%2;
                a[i].y=aa/2+aa%2;
            }
            a[i].flag=false;
        }
        sort(a+1,a+n+1,cmp);
        /*for(int i=1;i<=n;i++)
            printf("%d %d\n",a[i].x,a[i].y);*/
        int num=0,f;
        for(int i=1;i<=n;i++)
        {
            if(a[i].flag)
                continue;
            a[i].flag=true;
            f=a[i].y;
            num++;
            for(int j=i+1;j<=n;j++)
            {
                if(f<a[j].x&&a[j].flag==false)
                {
                    a[j].flag=true;
                    f=a[j].y;
                }
            }
        }
        printf("%d\n",num*10);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值